summaryrefslogtreecommitdiffstats
path: root/testsuites/tmtests/tm24/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/tmtests/tm24/Makefile.am')
-rw-r--r--testsuites/tmtests/tm24/Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/testsuites/tmtests/tm24/Makefile.am b/testsuites/tmtests/tm24/Makefile.am
index 42ed9a965a..3699ebe82f 100644
--- a/testsuites/tmtests/tm24/Makefile.am
+++ b/testsuites/tmtests/tm24/Makefile.am
@@ -2,19 +2,18 @@
## $Id$
##
-TEST = tm24
MANAGERS = io message
noinst_LIBRARIES = lib.a
lib_a_SOURCES = task1.c system.h ../include/timesys.h
-DOCS = $(TEST).doc
+DOCS = tm24.doc
OBJS = $(lib_a_OBJECTS)
-PGM = ${ARCH}/$(TEST).exe
+PGM = ${ARCH}/tm24.exe
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
@@ -26,10 +25,10 @@ $(project_bspdir)/tests/$(dirstamp):
@$(mkdir_p) $(project_bspdir)/tests
@: > $(project_bspdir)/tests/$(dirstamp)
-$(project_bspdir)/tests/$(TEST).exe: $(PGM) $(project_bspdir)/tests/$(dirstamp)
+$(project_bspdir)/tests/tm24.exe: $(PGM) $(project_bspdir)/tests/$(dirstamp)
$(INSTALL_PROGRAM) $< $@
-TMPINSTALL_FILES = $(project_bspdir)/tests/$(TEST).exe
+TMPINSTALL_FILES = $(project_bspdir)/tests/tm24.exe
$(PGM): ${ARCH}/$(dirstamp)