summaryrefslogtreecommitdiffstats
path: root/testsuites/tmtests/tm11/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/tmtests/tm11/Makefile.am')
-rw-r--r--testsuites/tmtests/tm11/Makefile.am20
1 files changed, 8 insertions, 12 deletions
diff --git a/testsuites/tmtests/tm11/Makefile.am b/testsuites/tmtests/tm11/Makefile.am
index 93a68b8985..0fe5eaf588 100644
--- a/testsuites/tmtests/tm11/Makefile.am
+++ b/testsuites/tmtests/tm11/Makefile.am
@@ -4,31 +4,27 @@
MANAGERS = io message
-noinst_LIBRARIES = lib.a
-lib_a_SOURCES = task1.c system.h ../include/timesys.h
+rtems_tests_PROGRAMS = tm11.exe
+tm11_exe_SOURCES = task1.c system.h ../include/timesys.h
-testsdir = $(libdir)/tests
-docdir = $(testsdir)
+docdir = $(rtems_testsdir)
dist_doc_DATA = tm11.doc
-OBJS = $(lib_a_OBJECTS)
-
-PGM = ${ARCH}/tm11.exe
-
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-$(PGM): ${ARCH}/$(dirstamp)
+tm11_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
OPERATION_COUNT = @OPERATION_COUNT@
AM_CPPFLAGS += -I$(top_srcdir)/include -DOPERATION_COUNT=$(OPERATION_COUNT)
-
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-tests_SCRIPTS = $(PGM)
+LINK_OBJS = $(tm11_exe_OBJECTS) $(tm11_exe_LDADD)
+LINK_LIBS = $(tm11_exe_LDLIBS)
-$(PGM): $(OBJS) $(LINK_FILES)
+tm11.exe$(EXEEXT): $(tm11_exe_OBJECTS) $(tm11_exe_DEPENDENCIES)
+ @rm -f tm11.exe$(EXEEXT)
$(make-exe)
include $(top_srcdir)/../automake/local.am