summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/spsize/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/spsize/Makefile.am')
-rw-r--r--testsuites/sptests/spsize/Makefile.am13
1 files changed, 6 insertions, 7 deletions
diff --git a/testsuites/sptests/spsize/Makefile.am b/testsuites/sptests/spsize/Makefile.am
index e39c56ccf9..e39972f174 100644
--- a/testsuites/sptests/spsize/Makefile.am
+++ b/testsuites/sptests/spsize/Makefile.am
@@ -2,18 +2,17 @@
## $Id$
##
-TEST = spsize
MANAGERS = io
noinst_LIBRARIES = lib.a
lib_a_SOURCES = init.c getint.c size.c system.h
-DOCS = $(TEST).scn
+DOCS = spsize.scn
OBJS = $(lib_a_OBJECTS)
-PGM = ${ARCH}/$(TEST).exe
+PGM = ${ARCH}/spsize.exe
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
@@ -25,18 +24,18 @@ $(project_bspdir)/tests/$(dirstamp):
@$(mkdir_p) $(project_bspdir)/tests
@: > $(project_bspdir)/tests/$(dirstamp)
-$(project_bspdir)/tests/$(TEST).exe: $(PGM) $(project_bspdir)/tests/$(dirstamp)
+$(project_bspdir)/tests/spsize.exe: $(PGM) $(project_bspdir)/tests/$(dirstamp)
$(INSTALL_PROGRAM) $< $@
$(project_bspdir)/tests/screens/sptests/$(dirstamp):
@$(mkdir_p) $(project_bspdir)/tests/screens/sptests
@: > $(project_bspdir)/tests/screens/sptests/$(dirstamp)
-$(project_bspdir)/tests/screens/sptests/$(TEST).scn: $(TEST).scn $(project_bspdir)/tests/screens/sptests/$(dirstamp)
+$(project_bspdir)/tests/screens/sptests/spsize.scn: spsize.scn $(project_bspdir)/tests/screens/sptests/$(dirstamp)
$(INSTALL_DATA) $< $@
-TMPINSTALL_FILES = $(project_bspdir)/tests/$(TEST).exe
-TMPINSTALL_FILES += $(project_bspdir)/tests/screens/sptests/$(TEST).scn
+TMPINSTALL_FILES = $(project_bspdir)/tests/spsize.exe
+TMPINSTALL_FILES += $(project_bspdir)/tests/screens/sptests/spsize.scn
$(PGM): ${ARCH}/$(dirstamp)