summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/spsize/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/spsize/Makefile.am')
-rw-r--r--testsuites/sptests/spsize/Makefile.am34
1 files changed, 6 insertions, 28 deletions
diff --git a/testsuites/sptests/spsize/Makefile.am b/testsuites/sptests/spsize/Makefile.am
index e39972f174..ab312d059e 100644
--- a/testsuites/sptests/spsize/Makefile.am
+++ b/testsuites/sptests/spsize/Makefile.am
@@ -2,13 +2,14 @@
## $Id$
##
-
MANAGERS = io
noinst_LIBRARIES = lib.a
lib_a_SOURCES = init.c getint.c size.c system.h
-DOCS = spsize.scn
+testsdir = $(libdir)/tests
+scndir = $(testsdir)
+dist_scn_DATA = spsize.scn
OBJS = $(lib_a_OBJECTS)
@@ -18,36 +19,13 @@ include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-project_bspdir=$(PROJECT_ROOT)
-
-$(project_bspdir)/tests/$(dirstamp):
- @$(mkdir_p) $(project_bspdir)/tests
- @: > $(project_bspdir)/tests/$(dirstamp)
-
-$(project_bspdir)/tests/spsize.exe: $(PGM) $(project_bspdir)/tests/$(dirstamp)
- $(INSTALL_PROGRAM) $< $@
-
-$(project_bspdir)/tests/screens/sptests/$(dirstamp):
- @$(mkdir_p) $(project_bspdir)/tests/screens/sptests
- @: > $(project_bspdir)/tests/screens/sptests/$(dirstamp)
-
-$(project_bspdir)/tests/screens/sptests/spsize.scn: spsize.scn $(project_bspdir)/tests/screens/sptests/$(dirstamp)
- $(INSTALL_DATA) $< $@
-
-TMPINSTALL_FILES = $(project_bspdir)/tests/spsize.exe
-TMPINSTALL_FILES += $(project_bspdir)/tests/screens/sptests/spsize.scn
-
$(PGM): ${ARCH}/$(dirstamp)
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-${PGM}: $(OBJS) $(LINK_FILES)
- $(make-exe)
-
-all-local: $(TMPINSTALL_FILES)
+tests_SCRIPTS = $(PGM)
-EXTRA_DIST = $(DOCS)
-
-CLEANFILES = $(TMPINSTALL_FILES)
+$(PGM): $(OBJS) $(LINK_FILES)
+ $(make-exe)
include $(top_srcdir)/../automake/local.am