summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/spsimplesched03/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/spsimplesched03/Makefile.am')
-rw-r--r--testsuites/sptests/spsimplesched03/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/testsuites/sptests/spsimplesched03/Makefile.am b/testsuites/sptests/spsimplesched03/Makefile.am
new file mode 100644
index 0000000000..d90e9ecb5e
--- /dev/null
+++ b/testsuites/sptests/spsimplesched03/Makefile.am
@@ -0,0 +1,28 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = spsimplesched03
+spsimplesched03_SOURCES = init.c
+
+dist_rtems_tests_DATA = spsimplesched03.scn
+dist_rtems_tests_DATA += spsimplesched03.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+spsimplesched03_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(spsimplesched03_OBJECTS) $(spsimplesched03_LDADD)
+LINK_LIBS = $(spsimplesched03_LDLIBS)
+
+spsimplesched03$(EXEEXT): $(spsimplesched03_OBJECTS) $(spsimplesched03_DEPENDENCIES)
+ @rm -f spsimplesched03$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am