summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp27/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/sp27/Makefile.am')
-rw-r--r--testsuites/sptests/sp27/Makefile.am37
1 files changed, 8 insertions, 29 deletions
diff --git a/testsuites/sptests/sp27/Makefile.am b/testsuites/sptests/sp27/Makefile.am
index f48cce3fd5..a8cff9fd0f 100644
--- a/testsuites/sptests/sp27/Makefile.am
+++ b/testsuites/sptests/sp27/Makefile.am
@@ -2,51 +2,30 @@
## $Id$
##
-
MANAGERS = all
noinst_LIBRARIES = lib.a
lib_a_SOURCES = init.c
-DOCS = sp27.doc sp27.scn
+testsdir = $(libdir)/tests
+scndir = $(testsdir)
+dist_scn_DATA = sp27.scn
+docdir = $(testsdir)
+dist_doc_DATA = sp27.doc
OBJS = $(lib_a_OBJECTS)
-
PGM = ${ARCH}/sp27.exe
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-project_bspdir=$(PROJECT_ROOT)
-
-$(project_bspdir)/tests/$(dirstamp):
- @$(mkdir_p) $(project_bspdir)/tests
- @: > $(project_bspdir)/tests/$(dirstamp)
-
-$(project_bspdir)/tests/sp27.exe: $(PGM) $(project_bspdir)/tests/$(dirstamp)
- $(INSTALL_PROGRAM) $< $@
-
-$(project_bspdir)/tests/screens/sptests/$(dirstamp):
- @$(mkdir_p) $(project_bspdir)/tests/screens/sptests
- @: > $(project_bspdir)/tests/screens/sptests/$(dirstamp)
-
-$(project_bspdir)/tests/screens/sptests/sp27.scn: sp27.scn $(project_bspdir)/tests/screens/sptests/$(dirstamp)
- $(INSTALL_DATA) $< $@
-
-TMPINSTALL_FILES = $(project_bspdir)/tests/sp27.exe
-TMPINSTALL_FILES += $(project_bspdir)/tests/screens/sptests/sp27.scn
-
$(PGM): ${ARCH}/$(dirstamp)
-${PGM}: $(OBJS) $(LINK_FILES)
- $(make-exe)
-
-all-local: $(TMPINSTALL_FILES)
-
-EXTRA_DIST = $(DOCS)
+tests_SCRIPTS = $(PGM)
-CLEANFILES = $(TMPINSTALL_FILES)
+$(PGM): $(OBJS) $(LINK_FILES)
+ $(make-exe)
include $(top_srcdir)/../automake/local.am