summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp26/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/sp26/Makefile.am')
-rw-r--r--testsuites/sptests/sp26/Makefile.am13
1 files changed, 6 insertions, 7 deletions
diff --git a/testsuites/sptests/sp26/Makefile.am b/testsuites/sptests/sp26/Makefile.am
index 80a49094ec..9a9495481c 100644
--- a/testsuites/sptests/sp26/Makefile.am
+++ b/testsuites/sptests/sp26/Makefile.am
@@ -2,19 +2,18 @@
## $Id$
##
-TEST = sp26
MANAGERS = io region event
noinst_LIBRARIES = lib.a
lib_a_SOURCES = init.c task1.c system.h
-DOCS = $(TEST).scn $(TEST).doc
+DOCS = sp26.scn sp26.doc
OBJS = $(lib_a_OBJECTS)
-PGM = ${ARCH}/$(TEST).exe
+PGM = ${ARCH}/sp26.exe
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
@@ -26,18 +25,18 @@ $(project_bspdir)/tests/$(dirstamp):
@$(mkdir_p) $(project_bspdir)/tests
@: > $(project_bspdir)/tests/$(dirstamp)
-$(project_bspdir)/tests/$(TEST).exe: $(PGM) $(project_bspdir)/tests/$(dirstamp)
+$(project_bspdir)/tests/sp26.exe: $(PGM) $(project_bspdir)/tests/$(dirstamp)
$(INSTALL_PROGRAM) $< $@
$(project_bspdir)/tests/screens/sptests/$(dirstamp):
@$(mkdir_p) $(project_bspdir)/tests/screens/sptests
@: > $(project_bspdir)/tests/screens/sptests/$(dirstamp)
-$(project_bspdir)/tests/screens/sptests/$(TEST).scn: $(TEST).scn $(project_bspdir)/tests/screens/sptests/$(dirstamp)
+$(project_bspdir)/tests/screens/sptests/sp26.scn: sp26.scn $(project_bspdir)/tests/screens/sptests/$(dirstamp)
$(INSTALL_DATA) $< $@
-TMPINSTALL_FILES = $(project_bspdir)/tests/$(TEST).exe
-TMPINSTALL_FILES += $(project_bspdir)/tests/screens/sptests/$(TEST).scn
+TMPINSTALL_FILES = $(project_bspdir)/tests/sp26.exe
+TMPINSTALL_FILES += $(project_bspdir)/tests/screens/sptests/sp26.scn
$(PGM): ${ARCH}/$(dirstamp)