summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp22/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/sp22/Makefile.am')
-rw-r--r--testsuites/sptests/sp22/Makefile.am15
1 files changed, 6 insertions, 9 deletions
diff --git a/testsuites/sptests/sp22/Makefile.am b/testsuites/sptests/sp22/Makefile.am
index 164c80dd20..d92760d764 100644
--- a/testsuites/sptests/sp22/Makefile.am
+++ b/testsuites/sptests/sp22/Makefile.am
@@ -6,24 +6,21 @@ TEST = sp22
MANAGERS = io timer
-C_FILES = init.c prtime.c delay.c task1.c
-C_O_FILES = $(C_FILES:%.c=${ARCH}/%.$(OBJEXT))
-
-H_FILES = system.h
-noinst_HEADERS = $(H_FILES)
+noinst_LIBRARIES = lib.a
+lib_a_SOURCES = init.c prtime.c delay.c task1.c system.h
DOCTYPES = scn doc
DOCS = $(DOCTYPES:%=$(TEST).%)
-SRCS = $(C_FILES) $(H_FILES)
-OBJS = $(C_O_FILES)
+SRCS =
+OBJS = $(lib_a_OBJECTS)
PRINT_SRCS = $(DOCS)
PGM = ${ARCH}/$(TEST).exe
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
-include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/amcompile.am
include $(top_srcdir)/../automake/leaf.am
include $(top_srcdir)/sptests.am
@@ -32,7 +29,7 @@ ${PGM}: $(OBJS) $(LINK_FILES)
all-local: $(TMPINSTALL_FILES)
-EXTRA_DIST = $(C_FILES) $(DOCS)
+EXTRA_DIST = $(DOCS)
CLEANFILES = $(TMPINSTALL_FILES)