summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp15/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/sp15/Makefile.am')
-rw-r--r--testsuites/sptests/sp15/Makefile.am37
1 files changed, 8 insertions, 29 deletions
diff --git a/testsuites/sptests/sp15/Makefile.am b/testsuites/sptests/sp15/Makefile.am
index b6b186ae42..bc0c2181c7 100644
--- a/testsuites/sptests/sp15/Makefile.am
+++ b/testsuites/sptests/sp15/Makefile.am
@@ -2,53 +2,32 @@
## $Id$
##
-
MANAGERS = io partition
noinst_LIBRARIES = lib.a
lib_a_SOURCES = init.c task1.c system.h
-DOCS = sp15.scn sp15.doc
+testsdir = $(libdir)/tests
+scndir = $(testsdir)
+dist_scn_DATA = sp15.scn
+docdir = $(testsdir)
+dist_doc_DATA = sp15.doc
OBJS = $(lib_a_OBJECTS)
-
PGM = ${ARCH}/sp15.exe
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-project_bspdir=$(PROJECT_ROOT)
-
-$(project_bspdir)/tests/$(dirstamp):
- @$(mkdir_p) $(project_bspdir)/tests
- @: > $(project_bspdir)/tests/$(dirstamp)
-
-$(project_bspdir)/tests/sp15.exe: $(PGM) $(project_bspdir)/tests/$(dirstamp)
- $(INSTALL_PROGRAM) $< $@
-
-$(project_bspdir)/tests/screens/sptests/$(dirstamp):
- @$(mkdir_p) $(project_bspdir)/tests/screens/sptests
- @: > $(project_bspdir)/tests/screens/sptests/$(dirstamp)
-
-$(project_bspdir)/tests/screens/sptests/sp15.scn: sp15.scn $(project_bspdir)/tests/screens/sptests/$(dirstamp)
- $(INSTALL_DATA) $< $@
-
-TMPINSTALL_FILES = $(project_bspdir)/tests/sp15.exe
-TMPINSTALL_FILES += $(project_bspdir)/tests/screens/sptests/sp15.scn
-
$(PGM): ${ARCH}/$(dirstamp)
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-${PGM}: $(OBJS) $(LINK_FILES)
- $(make-exe)
-
-all-local: $(TMPINSTALL_FILES)
-
-EXTRA_DIST = $(DOCS)
+tests_SCRIPTS = $(PGM)
-CLEANFILES = $(TMPINSTALL_FILES)
+$(PGM): $(OBJS) $(LINK_FILES)
+ $(make-exe)
include $(top_srcdir)/../automake/local.am