summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp09/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/sp09/Makefile.am')
-rw-r--r--testsuites/sptests/sp09/Makefile.am13
1 files changed, 6 insertions, 7 deletions
diff --git a/testsuites/sptests/sp09/Makefile.am b/testsuites/sptests/sp09/Makefile.am
index dea4737e4d..0cba23a682 100644
--- a/testsuites/sptests/sp09/Makefile.am
+++ b/testsuites/sptests/sp09/Makefile.am
@@ -2,7 +2,6 @@
## $Id$
##
-TEST = sp09
MANAGERS = io message dual_ported_memory event multi_processor region \
semaphore signal rate_monotonic timer partition
@@ -13,12 +12,12 @@ lib_a_SOURCES = init.c delay.c isr.c screen01.c screen02.c screen03.c screen04.c
screen11.c screen12.c screen13.c screen14.c task1.c task2.c task3.c \
task4.c system.h
-DOCS = $(TEST).scn $(TEST).doc
+DOCS = sp09.scn sp09.doc
OBJS = $(lib_a_OBJECTS)
-PGM = ${ARCH}/$(TEST).exe
+PGM = ${ARCH}/sp09.exe
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
@@ -30,18 +29,18 @@ $(project_bspdir)/tests/$(dirstamp):
@$(mkdir_p) $(project_bspdir)/tests
@: > $(project_bspdir)/tests/$(dirstamp)
-$(project_bspdir)/tests/$(TEST).exe: $(PGM) $(project_bspdir)/tests/$(dirstamp)
+$(project_bspdir)/tests/sp09.exe: $(PGM) $(project_bspdir)/tests/$(dirstamp)
$(INSTALL_PROGRAM) $< $@
$(project_bspdir)/tests/screens/sptests/$(dirstamp):
@$(mkdir_p) $(project_bspdir)/tests/screens/sptests
@: > $(project_bspdir)/tests/screens/sptests/$(dirstamp)
-$(project_bspdir)/tests/screens/sptests/$(TEST).scn: $(TEST).scn $(project_bspdir)/tests/screens/sptests/$(dirstamp)
+$(project_bspdir)/tests/screens/sptests/sp09.scn: sp09.scn $(project_bspdir)/tests/screens/sptests/$(dirstamp)
$(INSTALL_DATA) $< $@
-TMPINSTALL_FILES = $(project_bspdir)/tests/$(TEST).exe
-TMPINSTALL_FILES += $(project_bspdir)/tests/screens/sptests/$(TEST).scn
+TMPINSTALL_FILES = $(project_bspdir)/tests/sp09.exe
+TMPINSTALL_FILES += $(project_bspdir)/tests/screens/sptests/sp09.scn
$(PGM): ${ARCH}/$(dirstamp)