summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp07/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/sp07/Makefile.am')
-rw-r--r--testsuites/sptests/sp07/Makefile.am13
1 files changed, 6 insertions, 7 deletions
diff --git a/testsuites/sptests/sp07/Makefile.am b/testsuites/sptests/sp07/Makefile.am
index 18a77380ef..f58f30e226 100644
--- a/testsuites/sptests/sp07/Makefile.am
+++ b/testsuites/sptests/sp07/Makefile.am
@@ -2,7 +2,6 @@
## $Id$
##
-TEST = sp07
MANAGERS = io
@@ -10,12 +9,12 @@ noinst_LIBRARIES = lib.a
lib_a_SOURCES = init.c buffered_io.c task1.c task2.c task3.c task4.c taskexit.c \
tcreate.c tdelete.c trestart.c tstart.c system.h
-DOCS = $(TEST).scn $(TEST).doc
+DOCS = sp07.scn sp07.doc
OBJS = $(lib_a_OBJECTS)
-PGM = ${ARCH}/$(TEST).exe
+PGM = ${ARCH}/sp07.exe
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
@@ -27,18 +26,18 @@ $(project_bspdir)/tests/$(dirstamp):
@$(mkdir_p) $(project_bspdir)/tests
@: > $(project_bspdir)/tests/$(dirstamp)
-$(project_bspdir)/tests/$(TEST).exe: $(PGM) $(project_bspdir)/tests/$(dirstamp)
+$(project_bspdir)/tests/sp07.exe: $(PGM) $(project_bspdir)/tests/$(dirstamp)
$(INSTALL_PROGRAM) $< $@
$(project_bspdir)/tests/screens/sptests/$(dirstamp):
@$(mkdir_p) $(project_bspdir)/tests/screens/sptests
@: > $(project_bspdir)/tests/screens/sptests/$(dirstamp)
-$(project_bspdir)/tests/screens/sptests/$(TEST).scn: $(TEST).scn $(project_bspdir)/tests/screens/sptests/$(dirstamp)
+$(project_bspdir)/tests/screens/sptests/sp07.scn: sp07.scn $(project_bspdir)/tests/screens/sptests/$(dirstamp)
$(INSTALL_DATA) $< $@
-TMPINSTALL_FILES = $(project_bspdir)/tests/$(TEST).exe
-TMPINSTALL_FILES += $(project_bspdir)/tests/screens/sptests/$(TEST).scn
+TMPINSTALL_FILES = $(project_bspdir)/tests/sp07.exe
+TMPINSTALL_FILES += $(project_bspdir)/tests/screens/sptests/sp07.scn
$(PGM): ${ARCH}/$(dirstamp)