summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp07/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/sp07/Makefile.am')
-rw-r--r--testsuites/sptests/sp07/Makefile.am37
1 files changed, 8 insertions, 29 deletions
diff --git a/testsuites/sptests/sp07/Makefile.am b/testsuites/sptests/sp07/Makefile.am
index f58f30e226..6e9707a2c9 100644
--- a/testsuites/sptests/sp07/Makefile.am
+++ b/testsuites/sptests/sp07/Makefile.am
@@ -2,54 +2,33 @@
## $Id$
##
-
MANAGERS = io
noinst_LIBRARIES = lib.a
lib_a_SOURCES = init.c buffered_io.c task1.c task2.c task3.c task4.c taskexit.c \
tcreate.c tdelete.c trestart.c tstart.c system.h
-DOCS = sp07.scn sp07.doc
+testsdir = $(libdir)/tests
+scndir = $(testsdir)
+dist_scn_DATA = sp07.scn
+docdir = $(testsdir)
+dist_doc_DATA = sp07.doc
OBJS = $(lib_a_OBJECTS)
-
PGM = ${ARCH}/sp07.exe
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-project_bspdir=$(PROJECT_ROOT)
-
-$(project_bspdir)/tests/$(dirstamp):
- @$(mkdir_p) $(project_bspdir)/tests
- @: > $(project_bspdir)/tests/$(dirstamp)
-
-$(project_bspdir)/tests/sp07.exe: $(PGM) $(project_bspdir)/tests/$(dirstamp)
- $(INSTALL_PROGRAM) $< $@
-
-$(project_bspdir)/tests/screens/sptests/$(dirstamp):
- @$(mkdir_p) $(project_bspdir)/tests/screens/sptests
- @: > $(project_bspdir)/tests/screens/sptests/$(dirstamp)
-
-$(project_bspdir)/tests/screens/sptests/sp07.scn: sp07.scn $(project_bspdir)/tests/screens/sptests/$(dirstamp)
- $(INSTALL_DATA) $< $@
-
-TMPINSTALL_FILES = $(project_bspdir)/tests/sp07.exe
-TMPINSTALL_FILES += $(project_bspdir)/tests/screens/sptests/sp07.scn
-
$(PGM): ${ARCH}/$(dirstamp)
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-${PGM}: $(OBJS) $(LINK_FILES)
- $(make-exe)
-
-all-local: $(TMPINSTALL_FILES)
-
-EXTRA_DIST = $(DOCS)
+tests_SCRIPTS = $(PGM)
-CLEANFILES = $(TMPINSTALL_FILES)
+$(PGM): $(OBJS) $(LINK_FILES)
+ $(make-exe)
include $(top_srcdir)/../automake/local.am