summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/Makefile.am')
-rw-r--r--testsuites/sptests/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/testsuites/sptests/Makefile.am b/testsuites/sptests/Makefile.am
new file mode 100644
index 0000000000..0ccdebfde3
--- /dev/null
+++ b/testsuites/sptests/Makefile.am
@@ -0,0 +1,21 @@
+#
+# $Id$
+#
+
+AUTOMAKE_OPTIONS = foreign 1.4
+ACLOCAL_AMFLAGS = -I $(RTEMS_TOPdir)/aclocal
+
+project_bspdir=$(PROJECT_ROOT)/@RTEMS_BSP@
+
+PREINSTALLDIRS = $(project_bspdir)/tests/screens/sptests
+$(PREINSTALLDIRS):
+ @$(mkinstalldirs) $@
+
+all-local: $(PREINSTALLDIRS)
+
+# sp10 and spfatal are not included for now
+SUBDIRS = . sp01 sp02 sp03 sp04 sp05 sp06 sp07 sp08 sp09 sp11 sp12 sp13 sp14 \
+ sp15 sp16 sp17 sp19 sp20 sp21 sp22 sp23 sp24 sp25 spsize
+
+include $(top_srcdir)/../../../../automake/subdirs.am
+include $(top_srcdir)/../../../../automake/local.am