summaryrefslogtreecommitdiffstats
path: root/testsuites/smptests/smpatomic08/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/smptests/smpatomic08/Makefile.am')
-rw-r--r--testsuites/smptests/smpatomic08/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/testsuites/smptests/smpatomic08/Makefile.am b/testsuites/smptests/smpatomic08/Makefile.am
new file mode 100644
index 0000000000..f6abd55c49
--- /dev/null
+++ b/testsuites/smptests/smpatomic08/Makefile.am
@@ -0,0 +1,19 @@
+rtems_tests_PROGRAMS = smpatomic08
+smpatomic08_SOURCES = init.c
+
+dist_rtems_tests_DATA = smpatomic08.scn smpatomic08.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(smpatomic08_OBJECTS)
+LINK_LIBS = $(smpatomic08_LDLIBS)
+
+smpatomic08$(EXEEXT): $(smpatomic08_OBJECTS) $(smpatomic08_DEPENDENCIES)
+ @rm -f smpatomic08$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am