summaryrefslogtreecommitdiffstats
path: root/testsuites/samples/pppd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/samples/pppd/Makefile.am')
-rw-r--r--testsuites/samples/pppd/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/testsuites/samples/pppd/Makefile.am b/testsuites/samples/pppd/Makefile.am
new file mode 100644
index 0000000000..7e429e499d
--- /dev/null
+++ b/testsuites/samples/pppd/Makefile.am
@@ -0,0 +1,43 @@
+##
+## $Id$
+##
+
+
+SAMPLE = pppd
+PGM = ${ARCH}/$(SAMPLE).exe
+
+MANAGERS = io event semaphore
+
+C_FILES = init.c pppdapp.c
+C_O_FILES = $(C_FILES:%.c=${ARCH}/%.$(OBJEXT))
+
+H_FILES = netconfig.h system.h
+
+DOCTYPES = scn
+DOCS = $(DOCTYPES:%=$(SAMPLE).%)
+
+SRCS = $(DOCS) $(C_FILES) $(H_FILES)
+OBJS = $(C_O_FILES)
+
+PRINT_SRCS = $(DOCS)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../automake/compile.am
+include $(top_srcdir)/../../../../automake/leaf.am
+include $(top_srcdir)/sample.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+
+if HAS_NETWORKING
+all-local: ${ARCH} $(TMPINSTALL_FILES)
+
+${PGM}: $(OBJS) $(LINK_FILES)
+ $(make-exe)
+endif
+
+EXTRA_DIST = $(C_FILES) $(H_FILES) $(DOCS)
+
+include $(top_srcdir)/../../../../automake/local.am