summaryrefslogtreecommitdiffstats
path: root/testsuites/samples/loopback/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/samples/loopback/Makefile.am')
-rw-r--r--testsuites/samples/loopback/Makefile.am19
1 files changed, 8 insertions, 11 deletions
diff --git a/testsuites/samples/loopback/Makefile.am b/testsuites/samples/loopback/Makefile.am
index 471b33628a..1cd69f6504 100644
--- a/testsuites/samples/loopback/Makefile.am
+++ b/testsuites/samples/loopback/Makefile.am
@@ -2,28 +2,25 @@
## $Id$
##
-PGM = ${ARCH}/loopback.exe
-
MANAGERS = io event
-noinst_LIBRARIES = lib.a
-lib_a_SOURCES = init.c
+rtems_tests_PROGRAMS = loopback.exe
+loopback_exe_SOURCES = init.c
-testsdir = $(libdir)/tests
-scndir = $(testsdir)
+scndir = $(rtems_testsdir)
dist_scn_DATA = loopback.scn
-OBJS = $(lib_a_OBJECTS)
-
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-$(PGM): ${ARCH}/$(dirstamp)
+loopback_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
-tests_SCRIPTS = $(PGM)
+LINK_OBJS = $(loopback_exe_OBJECTS) $(loopback_exe_LDADD)
+LINK_LIBS = $(loopback_exe_LDLIBS)
-$(PGM): $(OBJS) $(LINK_FILES)
+loopback.exe$(EXEEXT): $(loopback_exe_OBJECTS) $(loopback_exe_DEPENDENCIES)
+ @rm -f loopback.exe$(EXEEXT)
$(make-exe)
include $(top_srcdir)/../automake/local.am