summaryrefslogtreecommitdiffstats
path: root/testsuites/samples/iostream/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/samples/iostream/Makefile.am')
-rw-r--r--testsuites/samples/iostream/Makefile.am13
1 files changed, 6 insertions, 7 deletions
diff --git a/testsuites/samples/iostream/Makefile.am b/testsuites/samples/iostream/Makefile.am
index 8c1edd6d9d..38d467ae35 100644
--- a/testsuites/samples/iostream/Makefile.am
+++ b/testsuites/samples/iostream/Makefile.am
@@ -2,15 +2,14 @@
## $Id$
##
-TEST = iostream
-PGM = ${ARCH}/$(TEST).exe
+PGM = ${ARCH}/iostream.exe
MANAGERS = io
noinst_LIBRARIES = lib.a
lib_a_SOURCES = init.cc system.h
-DOCS = $(TEST).doc $(TEST).scn
+DOCS = iostream.doc iostream.scn
OBJS = $(lib_a_OBJECTS)
@@ -28,14 +27,14 @@ $(project_bspdir)/tests/$(dirstamp):
@$(mkdir_p) $(project_bspdir)/tests
@: > $(project_bspdir)/tests/$(dirstamp)
-$(project_bspdir)/samples/$(TEST).exe: $(PGM) $(project_bspdir)/samples/$(dirstamp)
+$(project_bspdir)/samples/iostream.exe: $(PGM) $(project_bspdir)/samples/$(dirstamp)
$(INSTALL_PROGRAM) $< $@
-$(project_bspdir)/tests/$(TEST).exe: $(PGM) $(project_bspdir)/tests/$(dirstamp)
+$(project_bspdir)/tests/iostream.exe: $(PGM) $(project_bspdir)/tests/$(dirstamp)
$(INSTALL_PROGRAM) $< $@
-TMPINSTALL_FILES = $(project_bspdir)/tests/$(TEST).exe
-TMPINSTALL_FILES += $(project_bspdir)/samples/$(TEST).exe
+TMPINSTALL_FILES = $(project_bspdir)/tests/iostream.exe
+TMPINSTALL_FILES += $(project_bspdir)/samples/iostream.exe
$(PGM): ${ARCH}/$(dirstamp)