summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtmtests/psxtmnanosleep02/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/psxtmtests/psxtmnanosleep02/Makefile.am')
-rw-r--r--testsuites/psxtmtests/psxtmnanosleep02/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/testsuites/psxtmtests/psxtmnanosleep02/Makefile.am b/testsuites/psxtmtests/psxtmnanosleep02/Makefile.am
new file mode 100644
index 0000000000..45b270a2b7
--- /dev/null
+++ b/testsuites/psxtmtests/psxtmnanosleep02/Makefile.am
@@ -0,0 +1,30 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = psxtmnanosleep02
+psxtmnanosleep02_SOURCES = init.c ../../tmtests/include/timesys.h \
+ ../../support/src/tmtests_empty_function.c \
+ ../../support/src/tmtests_support.c
+
+dist_rtems_tests_DATA = psxtmnanosleep02.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+OPERATION_COUNT = @OPERATION_COUNT@
+AM_CPPFLAGS += -I$(top_srcdir)/../tmtests/include
+AM_CPPFLAGS += -DOPERATION_COUNT=$(OPERATION_COUNT)
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psxtmnanosleep02_OBJECTS) $(psxtmnanosleep02_LDADD)
+LINK_LIBS = $(psxtmnanosleep02_LDLIBS)
+
+psxtmnanosleep02$(EXEEXT): $(psxtmnanosleep02_OBJECTS) $(psxtmnanosleep02_DEPENDENCIES)
+ @rm -f psxtmnanosleep02$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am