summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/psxstat/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/psxtests/psxstat/Makefile.am')
-rw-r--r--testsuites/psxtests/psxstat/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/testsuites/psxtests/psxstat/Makefile.am b/testsuites/psxtests/psxstat/Makefile.am
index 3472e2137b..842f4e4995 100644
--- a/testsuites/psxtests/psxstat/Makefile.am
+++ b/testsuites/psxtests/psxstat/Makefile.am
@@ -6,21 +6,21 @@ TEST = psxstat
MANAGERS = all
-C_FILES = main.c test.c
-C_O_FILES = $(C_FILES:%.c=${ARCH}/%.$(OBJEXT))
+noinst_LIBRARIES = lib.a
+lib_a_SOURCES = main.c test.c
DOCTYPES = scn
DOCS = $(DOCTYPES:%=$(TEST).%)
-SRCS = $(DOCS) $(C_FILES) $(H_FILES)
-OBJS = $(C_O_FILES)
+SRCS = $(DOCS)
+OBJS = $(lib_a_OBJECTS)
PRINT_SRCS = $(DOCS)
PGM = ${ARCH}/$(TEST).exe
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
-include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/amcompile.am
include $(top_srcdir)/../automake/leaf.am
include $(top_srcdir)/psxtests.am
@@ -35,7 +35,7 @@ ${PGM}: $(OBJS) $(LINK_FILES)
all-local: $(TMPINSTALL_FILES)
-EXTRA_DIST = $(C_FILES) $(DOCS)
+EXTRA_DIST = $(DOCS)
CLEANFILES = $(TMPINSTALL_FILES)