summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/psx16/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/psxtests/psx16/Makefile.am')
-rw-r--r--testsuites/psxtests/psx16/Makefile.am17
1 files changed, 10 insertions, 7 deletions
diff --git a/testsuites/psxtests/psx16/Makefile.am b/testsuites/psxtests/psx16/Makefile.am
index 048d896440..3085bdd4ce 100644
--- a/testsuites/psxtests/psx16/Makefile.am
+++ b/testsuites/psxtests/psx16/Makefile.am
@@ -2,24 +2,27 @@
## $Id$
##
-rtems_tests_PROGRAMS = psx16
-psx16_SOURCES = init.c
+MANAGERS = all
+
+rtems_tests_PROGRAMS = psx16.exe
+psx16_exe_SOURCES = init.c
dist_rtems_tests_DATA = psx16.scn
-dist_rtems_tests_DATA += psx16.doc
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
+psx16_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
AM_CPPFLAGS += -I$(top_srcdir)/include
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-LINK_OBJS = $(psx16_OBJECTS) $(psx16_LDADD)
-LINK_LIBS = $(psx16_LDLIBS)
+LINK_OBJS = $(psx16_exe_OBJECTS) $(psx16_exe_LDADD)
+LINK_LIBS = $(psx16_exe_LDLIBS)
-psx16$(EXEEXT): $(psx16_OBJECTS) $(psx16_DEPENDENCIES)
- @rm -f psx16$(EXEEXT)
+psx16.exe$(EXEEXT): $(psx16_exe_OBJECTS) $(psx16_exe_DEPENDENCIES)
+ @rm -f psx16.exe$(EXEEXT)
$(make-exe)
include $(top_srcdir)/../automake/local.am