summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/psxtests/Makefile.am')
-rw-r--r--testsuites/psxtests/Makefile.am14
1 files changed, 6 insertions, 8 deletions
diff --git a/testsuites/psxtests/Makefile.am b/testsuites/psxtests/Makefile.am
index 937dec902f..7fe7e2d642 100644
--- a/testsuites/psxtests/Makefile.am
+++ b/testsuites/psxtests/Makefile.am
@@ -5,20 +5,18 @@
AUTOMAKE_OPTIONS = foreign 1.4
ACLOCAL_AMFLAGS = -I $(RTEMS_TOPdir)/aclocal
-project_bspdir = $(PROJECT_ROOT)/@RTEMS_BSP@
-
-PREINSTALLDIRS = $(project_bspdir)/tests/screens/psxtests
-$(PREINSTALLDIRS):
- @$(mkinstalldirs) $@
-
-all-local: $(PREINSTALLDIRS)
+SHARED_DIRS = filesupp support
POSIX_DIRS = psxhdrs psx01 psx02 psx03 psx04 psx05 psx06 psx07 psx08 psx09 \
psx10 psx11 psx12 psxtime psxtimer psxcancel psxmsgq01 psxsem01
POSIX_FILES_DIRS = psxfile01 psxreaddir psxstat psxmount psx13
-SUBDIRS = . support $(POSIX_DIRS) $(POSIX_FILES_DIRS)
+UNUSED_DIRS = psxfile02
+
+SUBDIRS = $(SHARED_DIRS) $(POSIX_DIRS) $(POSIX_FILES_DIRS) $(UNUSED_DIRS)
+
+EXTRA_DIST = psxtests.am
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am