summaryrefslogtreecommitdiffstats
path: root/testsuites/mptests/mp12/node2/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/mptests/mp12/node2/Makefile.am')
-rw-r--r--testsuites/mptests/mp12/node2/Makefile.am21
1 files changed, 9 insertions, 12 deletions
diff --git a/testsuites/mptests/mp12/node2/Makefile.am b/testsuites/mptests/mp12/node2/Makefile.am
index fead43b668..67005171c1 100644
--- a/testsuites/mptests/mp12/node2/Makefile.am
+++ b/testsuites/mptests/mp12/node2/Makefile.am
@@ -2,34 +2,31 @@
## $Id$
##
-PGM = $(ARCH)/mp12-node2.exe
-
MANAGERS = io mp partition
-noinst_LIBRARIES = lib.a
-lib_a_SOURCES = ../init.c ../system.h
+rtems_tests_PROGRAMS = mp12-node2.exe
+mp12_node2_exe_SOURCES = ../init.c ../system.h
-testsdir = $(libdir)/tests
-scndir = $(testsdir)
+scndir = $(rtems_testsdir)
dist_scn_DATA = mp12-node2.scn
-docdir = $(testsdir)
+docdir = $(rtems_testsdir)
dist_doc_DATA = mp12-node2.doc
-OBJS = $(lib_a_OBJECTS)
-
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-$(PGM): ${ARCH}/$(dirstamp)
+mp12_node2_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
AM_CPPFLAGS += -DNODE_NUMBER=2 -I$(srcdir)/..
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-tests_SCRIPTS = $(PGM)
+LINK_OBJS = $(mp12_node2_exe_OBJECTS) $(mp12_node2_exe_LDADD)
+LINK_LIBS = $(mp12_node2_exe_LDLIBS)
-$(PGM): $(OBJS) $(LINK_FILES)
+mp12-node2.exe$(EXEEXT): $(mp12_node2_exe_OBJECTS) $(mp12_node2_exe_DEPENDENCIES)
+ @rm -f mp12-node2.exe$(EXEEXT)
$(make-exe)
include $(top_srcdir)/../automake/local.am