summaryrefslogtreecommitdiffstats
path: root/testsuites/mptests/mp07/node2/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/mptests/mp07/node2/Makefile.am')
-rw-r--r--testsuites/mptests/mp07/node2/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/testsuites/mptests/mp07/node2/Makefile.am b/testsuites/mptests/mp07/node2/Makefile.am
index 0f5b8409cd..a2061ac677 100644
--- a/testsuites/mptests/mp07/node2/Makefile.am
+++ b/testsuites/mptests/mp07/node2/Makefile.am
@@ -2,16 +2,17 @@
## $Id$
##
-VPATH = @srcdir@:@srcdir@/..
-
NODE = 2
TEST = mp07
PGM = ${ARCH}/$(TEST)-node$(NODE).exe
MANAGERS = io mp event timer
-C_FILES = init.c task1.c
-C_O_FILES = $(C_FILES:%.c=${ARCH}/%.$(OBJEXT))
+C_FILES = ../init.c ../task1.c
+C_O_FILES = $(C_FILES:../%.c=${ARCH}/%.$(OBJEXT))
+
+$(ARCH)/%$(LIB_VARIANT).$(OBJEXT): ../%.c $(ARCH)/$(dirstamp)
+ ${COMPILE} -o $@ -c $<
H_FILES = system.h