summaryrefslogtreecommitdiffstats
path: root/testsuites/libtests/termios/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/libtests/termios/Makefile.am')
-rw-r--r--testsuites/libtests/termios/Makefile.am26
1 files changed, 4 insertions, 22 deletions
diff --git a/testsuites/libtests/termios/Makefile.am b/testsuites/libtests/termios/Makefile.am
index a6fe4905d7..31197d6826 100644
--- a/testsuites/libtests/termios/Makefile.am
+++ b/testsuites/libtests/termios/Makefile.am
@@ -2,46 +2,28 @@
## $Id$
##
-
MANAGERS = io
noinst_LIBRARIES = lib.a
lib_a_SOURCES = init.c
-DOCS =
+testsdir = $(libdir)/tests
OBJS = $(lib_a_OBJECTS)
-
PGM = ${ARCH}/termios.exe
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-project_bspdir=$(PROJECT_ROOT)
-
-$(project_bspdir)/tests/$(dirstamp):
- @$(mkdir_p) $(project_bspdir)/tests
- @: > $(project_bspdir)/tests/$(dirstamp)
-
-$(project_bspdir)/tests/termios.exe: $(PGM) $(project_bspdir)/tests/$(dirstamp)
- $(INSTALL_PROGRAM) $< $@
-
-TMPINSTALL_FILES = $(project_bspdir)/tests/termios.exe
-
$(PGM): ${ARCH}/$(dirstamp)
-
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-${PGM}: $(OBJS) $(LINK_FILES)
- $(make-exe)
-
-all-local: $(TMPINSTALL_FILES)
+tests_SCRIPTS = $(PGM)
-EXTRA_DIST = $(DOCS)
-
-CLEANFILES = $(TMPINSTALL_FILES)
+$(PGM): $(OBJS) $(LINK_FILES)
+ $(make-exe)
include $(top_srcdir)/../automake/local.am