summaryrefslogtreecommitdiffstats
path: root/testsuites/libtests/stackchk/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/libtests/stackchk/Makefile.am')
-rw-r--r--testsuites/libtests/stackchk/Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/testsuites/libtests/stackchk/Makefile.am b/testsuites/libtests/stackchk/Makefile.am
index 39f0dac4b8..42fc0d455b 100644
--- a/testsuites/libtests/stackchk/Makefile.am
+++ b/testsuites/libtests/stackchk/Makefile.am
@@ -2,19 +2,18 @@
## $Id$
##
-TEST = stackchk
MANAGERS = io
noinst_LIBRARIES = lib.a
lib_a_SOURCES = blow.c init.c task1.c system.h
-DOCS = $(TEST).scn
+DOCS = stackchk.scn
OBJS = $(lib_a_OBJECTS)
-PGM = ${ARCH}/$(TEST).exe
+PGM = ${ARCH}/stackchk.exe
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
@@ -26,10 +25,10 @@ $(project_bspdir)/tests/$(dirstamp):
@$(mkdir_p) $(project_bspdir)/tests
@: > $(project_bspdir)/tests/$(dirstamp)
-$(project_bspdir)/tests/$(TEST).exe: $(PGM) $(project_bspdir)/tests/$(dirstamp)
+$(project_bspdir)/tests/stackchk.exe: $(PGM) $(project_bspdir)/tests/$(dirstamp)
$(INSTALL_PROGRAM) $< $@
-TMPINSTALL_FILES = $(project_bspdir)/tests/$(TEST).exe
+TMPINSTALL_FILES = $(project_bspdir)/tests/stackchk.exe
$(PGM): ${ARCH}/$(dirstamp)