summaryrefslogtreecommitdiffstats
path: root/testsuites/libtests/putenvtest/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/libtests/putenvtest/Makefile.am')
-rw-r--r--testsuites/libtests/putenvtest/Makefile.am18
1 files changed, 7 insertions, 11 deletions
diff --git a/testsuites/libtests/putenvtest/Makefile.am b/testsuites/libtests/putenvtest/Makefile.am
index 4d4a30114a..5254bbc0cc 100644
--- a/testsuites/libtests/putenvtest/Makefile.am
+++ b/testsuites/libtests/putenvtest/Makefile.am
@@ -4,26 +4,22 @@
MANAGERS = io
-noinst_LIBRARIES = lib.a
-lib_a_SOURCES = init.c
-
-testsdir = $(libdir)/tests
-
-OBJS = $(lib_a_OBJECTS)
-
-PGM = ${ARCH}/putenvtest.exe
+rtems_tests_PROGRAMS = putenvtest.exe
+putenvtest_exe_SOURCES = init.c
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-$(PGM): ${ARCH}/$(dirstamp)
+putenvtest_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-tests_SCRIPTS = $(PGM)
+LINK_OBJS = $(putenvtest_exe_OBJECTS) $(putenvtest_exe_LDADD)
+LINK_LIBS = $(putenvtest_exe_LDLIBS)
-$(PGM): $(OBJS) $(LINK_FILES)
+putenvtest.exe$(EXEEXT): $(putenvtest_exe_OBJECTS) $(putenvtest_exe_DEPENDENCIES)
+ @rm -f putenvtest.exe$(EXEEXT)
$(make-exe)
include $(top_srcdir)/../automake/local.am