summaryrefslogtreecommitdiffstats
path: root/testsuites/libtests/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/libtests/configure.ac')
-rw-r--r--testsuites/libtests/configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/testsuites/libtests/configure.ac b/testsuites/libtests/configure.ac
index 1cc5943f7f..7c82394c11 100644
--- a/testsuites/libtests/configure.ac
+++ b/testsuites/libtests/configure.ac
@@ -44,9 +44,12 @@ AM_CONDITIONAL(HAS_POSIX,test x"${rtems_cv_RTEMS_POSIX_API}" = x"yes")
# Must match the list in cpukit.
AC_MSG_CHECKING([whether CPU supports libdl])
case $RTEMS_CPU in
- arm | bfin | h8300 | i386 | lm32 | m32r | m68k | mips | \
+ arm | h8300 | i386 | lm32 | m32r | m68k | mips | \
moxie | powerpc | sparc | v850)
TEST_LIBDL=yes ;;
+ # bfin has an issue to resolve with libdl. See ticket #2252
+ bfin)
+ HAVE_LIBDL=no ;;
*)
TEST_LIBDL=no ;;
esac