summaryrefslogtreecommitdiffstats
path: root/testsuites/itrontests/itrontask02/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/itrontests/itrontask02/Makefile.am')
-rw-r--r--testsuites/itrontests/itrontask02/Makefile.am24
1 files changed, 23 insertions, 1 deletions
diff --git a/testsuites/itrontests/itrontask02/Makefile.am b/testsuites/itrontests/itrontask02/Makefile.am
index 06f8fac64f..fe77ffba4e 100644
--- a/testsuites/itrontests/itrontask02/Makefile.am
+++ b/testsuites/itrontests/itrontask02/Makefile.am
@@ -18,7 +18,29 @@ OBJS = $(lib_a_OBJECTS)
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-include $(top_srcdir)/itrontests.am
+
+project_bspdir=$(PROJECT_ROOT)
+
+$(project_bspdir)/tests/$(dirstamp):
+ @$(mkdir_p) $(project_bspdir)/tests
+ @: > $(project_bspdir)/tests/$(dirstamp)
+
+$(project_bspdir)/tests/$(TEST).exe: $(PGM) $(project_bspdir)/tests/$(dirstamp)
+ $(INSTALL_PROGRAM) $< $@
+
+$(project_bspdir)/tests/screens/itrontests/$(dirstamp):
+ @$(mkdir_p) $(project_bspdir)/tests/screens/itrontests
+ @: > $(project_bspdir)/tests/screens/itrontests/$(dirstamp)
+
+$(project_bspdir)/tests/screens/itrontests/$(TEST).scn: $(TEST).scn $(project_bspdir)/tests/screens/itrontests/$(dirstamp)
+ $(INSTALL_DATA) $< $@
+
+TMPINSTALL_FILES = \
+$(project_bspdir)/tests/$(TEST).exe \
+$(project_bspdir)/tests/screens/itrontests/$(TEST).scn
+
+$(PGM): ${ARCH}/$(dirstamp)
+
#
# (OPTIONAL) Add local stuff here using +=