summaryrefslogtreecommitdiffstats
path: root/testsuites/itrontests/itrontask01/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/itrontests/itrontask01/Makefile.am')
-rw-r--r--testsuites/itrontests/itrontask01/Makefile.am21
1 files changed, 9 insertions, 12 deletions
diff --git a/testsuites/itrontests/itrontask01/Makefile.am b/testsuites/itrontests/itrontask01/Makefile.am
index 54d6817850..3682072559 100644
--- a/testsuites/itrontests/itrontask01/Makefile.am
+++ b/testsuites/itrontests/itrontask01/Makefile.am
@@ -2,32 +2,29 @@
## $Id$
##
-PGM = ${ARCH}/itrontask01.exe
-
MANAGERS = all
-noinst_LIBRARIES = lib.a
-lib_a_SOURCES = init.c task1.c system.h
+rtems_tests_PROGRAMS = itrontask01.exe
+itrontask01_exe_SOURCES = init.c task1.c system.h
-testsdir = $(libdir)/tests
-scndir = $(testsdir)
+scndir = $(rtems_testsdir)
dist_scn_DATA = itrontask01.scn
-docdir = $(testsdir)
+docdir = $(rtems_testsdir)
dist_doc_DATA = itrontask01.doc
-OBJS = $(lib_a_OBJECTS)
-
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-$(PGM): ${ARCH}/$(dirstamp)
+itrontask01_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-tests_SCRIPTS = $(PGM)
+LINK_OBJS = $(itrontask01_exe_OBJECTS) $(itrontask01_exe_LDADD)
+LINK_LIBS = $(itrontask01_exe_LDLIBS)
-$(PGM): $(OBJS) $(LINK_FILES)
+itrontask01.exe$(EXEEXT): $(itrontask01_exe_OBJECTS) $(itrontask01_exe_DEPENDENCIES)
+ @rm -f itrontask01.exe$(EXEEXT)
$(make-exe)
include $(top_srcdir)/../automake/local.am