summaryrefslogtreecommitdiffstats
path: root/testsuites/itrontests/itronhello/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/itrontests/itronhello/Makefile.am')
-rw-r--r--testsuites/itrontests/itronhello/Makefile.am39
1 files changed, 8 insertions, 31 deletions
diff --git a/testsuites/itrontests/itronhello/Makefile.am b/testsuites/itrontests/itronhello/Makefile.am
index 5a542f8daa..f00d66ebe5 100644
--- a/testsuites/itrontests/itronhello/Makefile.am
+++ b/testsuites/itrontests/itronhello/Makefile.am
@@ -9,48 +9,25 @@ MANAGERS = all
noinst_LIBRARIES = lib.a
lib_a_SOURCES = init.c system.h
-DOCS = itronhello.doc itronhello.scn
+testsdir = $(libdir)/tests
+scndir = $(testsdir)
+dist_scn_DATA = itronhello.scn
+docdir = $(testsdir)
+dist_doc_DATA = itronhello.doc
OBJS = $(lib_a_OBJECTS)
-
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-project_bspdir=$(PROJECT_ROOT)
-
-$(project_bspdir)/tests/$(dirstamp):
- @$(mkdir_p) $(project_bspdir)/tests
- @: > $(project_bspdir)/tests/$(dirstamp)
-
-$(project_bspdir)/tests/itronhello.exe: $(PGM) $(project_bspdir)/tests/$(dirstamp)
- $(INSTALL_PROGRAM) $< $@
-
-$(project_bspdir)/tests/screens/itrontests/$(dirstamp):
- @$(mkdir_p) $(project_bspdir)/tests/screens/itrontests
- @: > $(project_bspdir)/tests/screens/itrontests/$(dirstamp)
-
-$(project_bspdir)/tests/screens/itrontests/itronhello.scn: itronhello.scn $(project_bspdir)/tests/screens/itrontests/$(dirstamp)
- $(INSTALL_DATA) $< $@
-
-TMPINSTALL_FILES = \
-$(project_bspdir)/tests/itronhello.exe \
-$(project_bspdir)/tests/screens/itrontests/itronhello.scn
-
$(PGM): ${ARCH}/$(dirstamp)
-
-
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-${PGM}: $(OBJS) $(LINK_FILES)
- $(make-exe)
-
-all-local: $(TMPINSTALL_FILES)
-
-EXTRA_DIST = $(DOCS)
+tests_SCRIPTS = $(PGM)
-CLEANFILES = $(TMPINSTALL_FILES)
+$(PGM): $(OBJS) $(LINK_FILES)
+ $(make-exe)
include $(top_srcdir)/../automake/local.am