summaryrefslogtreecommitdiffstats
path: root/scripts/gccnewlib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/gccnewlib/Makefile.am')
-rw-r--r--scripts/gccnewlib/Makefile.am22
1 files changed, 12 insertions, 10 deletions
diff --git a/scripts/gccnewlib/Makefile.am b/scripts/gccnewlib/Makefile.am
index 21d17de771..c3f6f467d7 100644
--- a/scripts/gccnewlib/Makefile.am
+++ b/scripts/gccnewlib/Makefile.am
@@ -1,33 +1,35 @@
+## $Id$
+
AUTOMAKE_OPTIONS = foreign
-MKGCCNEWLIBSPEC = $(SHELL) ../mkgccnewlibspec
+MKGCCNEWLIBSPEC = $(SHELL) $(top_builddir)/mkgccnewlibspec
MKGCCNEWLIBSPEC_DEPS = \
- ../mkgccnewlibspec gccnewlib.spec.in ../setup.cache
+ $(top_builddir)/mkgccnewlibspec gccnewlib.spec.in $(top_builddir)/setup.cache
i386-rtems-$(GCCNEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
- $(MKGCCNEWLIBSPEC) -cfg ../setup.cache -o . i386-rtems
+ $(MKGCCNEWLIBSPEC) -cfg $(top_builddir)/setup.cache -o . i386-rtems
sh-rtems-$(GCCNEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
- $(MKGCCNEWLIBSPEC) -cfg ../setup.cache -o . sh-rtems
+ $(MKGCCNEWLIBSPEC) -cfg $(top_builddir)/setup.cache -o . sh-rtems
powerpc-rtems-$(GCCNEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
- $(MKGCCNEWLIBSPEC) -cfg ../setup.cache -o . powerpc-rtems
+ $(MKGCCNEWLIBSPEC) -cfg $(top_builddir)/setup.cache -o . powerpc-rtems
sparc-rtems-$(GCCNEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
- $(MKGCCNEWLIBSPEC) -cfg ../setup.cache -o . sparc-rtems
+ $(MKGCCNEWLIBSPEC) -cfg $(top_builddir)/setup.cache -o . sparc-rtems
m68k-rtems-$(GCCNEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
- $(MKGCCNEWLIBSPEC) -cfg ../setup.cache -o . m68k-rtems
+ $(MKGCCNEWLIBSPEC) -cfg $(top_builddir)/setup.cache -o . m68k-rtems
mips64orion-rtems-$(GCCNEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
- $(MKGCCNEWLIBSPEC) -cfg ../setup.cache -o . mips64orion-rtems
+ $(MKGCCNEWLIBSPEC) -cfg $(top_builddir)/setup.cache -o . mips64orion-rtems
i960-rtems-$(GCCNEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
- $(MKGCCNEWLIBSPEC) -cfg ../setup.cache -o . i960-rtems
+ $(MKGCCNEWLIBSPEC) -cfg $(top_builddir)/setup.cache -o . i960-rtems
hppa1.1-rtems-$(GCCNEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
- $(MKGCCNEWLIBSPEC) -cfg ../setup.cache -o . hppa1.1-rtems
+ $(MKGCCNEWLIBSPEC) -cfg $(top_builddir)/setup.cache -o . hppa1.1-rtems
TEMPLATES = \
gccnewlib.spec.in