summaryrefslogtreecommitdiffstats
path: root/scripts/cpukit/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--scripts/cpukit/Makefile.am16
1 files changed, 11 insertions, 5 deletions
diff --git a/scripts/cpukit/Makefile.am b/scripts/cpukit/Makefile.am
index d17f183083..03a95b87e3 100644
--- a/scripts/cpukit/Makefile.am
+++ b/scripts/cpukit/Makefile.am
@@ -5,9 +5,18 @@
MKSPEC = $(SHELL) ./mkspec
+SUBPACKAGES = header.add
+SUBPACKAGES += $(top_builddir)/common/common.add
+SUBPACKAGES += rtems-cpukit.add
+SUBPACKAGES += $(top_builddir)/common/clean.add
+
MKSPEC_DEPS = mkspec rtems-cpukit.spec.in \
$(top_builddir)/setup.cache
+rtems-cpukit.spec.in: $(SUBPACKAGES)
+ cat $^ > $@
+CLEANFILES = rtems-cpukit.spec.in
+
c4x-rtems-cpukit.spec: $(MKSPEC_DEPS)
$(MKSPEC) -cfg $(top_builddir)/setup.cache -o . c4x-rtems > $@
RPM_SPECS_DATA = c4x-rtems-cpukit.spec
@@ -56,11 +65,8 @@ sparc-rtems-cpukit.spec: $(MKSPEC_DEPS)
$(MKSPEC) -cfg $(top_builddir)/setup.cache -o . sparc-rtems > $@
RPM_SPECS_DATA += sparc-rtems-cpukit.spec
-TEMPLATES = rtems-cpukit.spec.in
-
-noinst_DATA = $(TEMPLATES)
+EXTRA_DIST = $(SUBPACKAGES)
-EXTRA_DIST = $(TEMPLATES)
+CLEANFILES += $(RPM_SPECS_DATA)
-CLEANFILES = $(RPM_SPECS_DATA)
include $(top_srcdir)/../automake/local.am