summaryrefslogtreecommitdiffstats
path: root/scripts/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/configure.in')
-rw-r--r--scripts/configure.in24
1 files changed, 16 insertions, 8 deletions
diff --git a/scripts/configure.in b/scripts/configure.in
index af2b918ecf..f2f2cd0cb9 100644
--- a/scripts/configure.in
+++ b/scripts/configure.in
@@ -2,9 +2,19 @@
AC_INIT(binutils)
-AM_INIT_AUTOMAKE(rtems-scripts,20000610-0,no)
+AM_INIT_AUTOMAKE(rtems-scripts,20010516,no)
-AC_EXEEXT
+AC_CANONICAL_HOST
+
+# Check for .exe suffix.
+# With autoconf > 2.13 AC_EXEEXT is not what we want to use.
+AC_MSG_CHECKING([for executable suffix])
+case "$host" in
+i?86-*cygwin*)
+ EXEEXT=.exe ;;
+esac
+AC_SUBST(EXEEXT)
+AC_MSG_RESULT([$EXEEXT])
test -f ./setup.cache || cp ${srcdir}/setup.def ./setup.cache
. ./setup.cache
@@ -32,13 +42,11 @@ fi
AC_MSG_RESULT($RPM_SPECSdir)
AC_SUBST(RPM_SPECSdir)
-AC_CANONICAL_HOST
-
AC_MSG_CHECKING(for RPM CPU type)
-case "${host}" in
- i[[34567]]86-*linux*) RPM_CPU=i386 ;;
- i[[34567]]86-pc-cygwin*) RPM_CPU=i386 ;;
- sparc-sun-solaris*) RPM_CPU=sparc ;;
+case "$host" in
+ i?86-*linux*) RPM_CPU=i386 ;;
+ i?86-*cygwin*) RPM_CPU=i386 ;;
+ sparc-sun-solaris*) RPM_CPU=sparc ;;
*)
AC_MSG_ERROR([RPM CPU for ${host} is unknown])
;;