summaryrefslogtreecommitdiffstats
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am15
1 files changed, 10 insertions, 5 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index b04ad1bc03..c489979d7d 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -18,12 +18,17 @@ CONFIG_STATUS_DEPENDENCIES = setup.cache
setup.cache: setup.def
cp setup.def $@
-DISTCLEANFILES = setup.cache
-
+rtems_source_spec_DEPS = common/common.add rtems/rtems-source.add \
+ common/clean.add
noinst_DATA += rtems/rtems-source.spec
-rtems/rtems-source.spec: $(top_builddir)/common/common.add rtems/rtems-source.add \
- $(top_builddir)/common/clean.add
- cat $^ | sed 's,[@]rtems_version[@],$(RTEMS_VERSION),g' > $@
+rtems/rtems-source.spec: $(rtems_source_spec_DEPS)
+ cat $(rtems_source_spec_DEPS) | sed \
+ -e 's,[@]rtems_version[@],$(RTEMS_VERSION),g' \
+ -e 's,[@]RTEMS_RPM_RELEASE[@],$(RTEMS_RPM_RELEASE),g' > $@
+
+CLEANFILES = rtems/rtems-source.spec
+
+DISTCLEANFILES = setup.cache
include $(top_srcdir)/../automake/subdirs.am
include $(top_srcdir)/../automake/local.am