summaryrefslogtreecommitdiffstats
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
new file mode 100644
index 0000000000..01acec5f32
--- /dev/null
+++ b/scripts/Makefile.am
@@ -0,0 +1,34 @@
+AUTOMAKE_OPTIONS = foreign
+
+SUBDIRS = . binutils gccnewlib
+
+noinst_SCRIPTS = \
+setup \
+buildall \
+mkbinutils_subpackage_version \
+mkbinutilspec \
+mkbspspec \
+mkgccnewlibspec \
+mkgdbspec \
+mkrpms \
+mkspec \
+mktoolspec
+
+TEMPLATES = \
+gccnewlib.spec.in \
+gdb.spec.in \
+rtems.spec.in \
+toolchain.spec.in
+
+noinst_DATA = \
+setup.def $(TEMPLATES)
+
+EXTRA_DIST = \
+$(noinst_DATA) \
+$(noinst_SCRIPTS)
+
+CONFIGURE_DEPENDENCIES = setup.cache
+setup.cache: setup.def
+ cp setup.def $@
+
+DISTCLEANFILES = setup.cache