summaryrefslogtreecommitdiffstats
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 751f50a970..85744fce12 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -18,6 +18,14 @@ CONFIG_STATUS_DEPENDENCIES = setup.cache
setup.cache: setup.def
cp setup.def $@
+noinst_DATA += rtems/rtems-source.spec
+rtems/rtems-source.spec: common/common.add \
+ rtems/rtems-source.add \
+ common/clean.add
+ cat $^ | sed 's,[@]rtems_version[@],$(RTEMS_VERSION),g' > $@
+
+CLEANFILES = rtems/rtems-source.spec
+
DISTCLEANFILES = setup.cache
include $(top_srcdir)/../automake/subdirs.am
include $(top_srcdir)/../automake/local.am