summaryrefslogtreecommitdiffstats
path: root/scripts-ada/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'scripts-ada/configure.in')
-rw-r--r--scripts-ada/configure.in51
1 files changed, 51 insertions, 0 deletions
diff --git a/scripts-ada/configure.in b/scripts-ada/configure.in
new file mode 100644
index 0000000000..d09ed57f4b
--- /dev/null
+++ b/scripts-ada/configure.in
@@ -0,0 +1,51 @@
+## $Id$
+
+AC_INIT(binutils)
+AM_INIT_AUTOMAKE(scripts,20000125-0,no)
+
+AC_EXEEXT
+
+test -f ./setup.cache || cp ${srcdir}/setup.def ./setup.cache
+. ./setup.cache
+
+# Some linux distributions use /usr/src/packages
+# redhat uses /usr/src/redhat
+# others might use /usr/src
+AC_MSG_CHECKING(for rpm SPECS directory)
+if test -d /usr/src/packages/SPECS;
+then
+ RPM_SPECSdir=/usr/src/packages/SPECS;
+elif test -d /usr/src/redhat/SPECS;
+then
+ RPM_SPECSdir=/usr/src/redhat/SPECS;
+elif test -d /usr/src/SPECS/;
+then
+ RPM_SPECSdir=/usr/src/SPECS;
+fi
+if test x"$RPM_SPECSdir" = x"" ; then
+AC_MSG_ERROR(not found)
+fi
+AC_MSG_RESULT($RPM_SPECSdir)
+AC_SUBST(RPM_SPECSdir)
+
+GCCNEWLIBVERS="gcc-${gcc_version}-newlib-${newlib_version}"
+AC_SUBST(GCCNEWLIBVERS)
+BINUTILSVERS="binutils-${binutils_version}"
+AC_SUBST(BINUTILSVERS)
+GDBVERS="gdb-${gdb_version}"
+AC_SUBST(GDBVERS)
+BSPVERS="${rtems_version}"
+AC_SUBST(RTEMS_VERSION)
+AC_SUBST(BSPVERS)
+
+AC_OUTPUT(
+Makefile
+buildall
+mkbinutilspec
+mkgnatnewlibspec
+mkgdbspec
+mkbspspec
+binutils/Makefile
+gnatnewlib/Makefile
+gdb/Makefile
+)