summaryrefslogtreecommitdiffstats
path: root/doc/user/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/user/Makefile.am')
-rw-r--r--doc/user/Makefile.am167
1 files changed, 81 insertions, 86 deletions
diff --git a/doc/user/Makefile.am b/doc/user/Makefile.am
index a08e2df0d7..c90de31c32 100644
--- a/doc/user/Makefile.am
+++ b/doc/user/Makefile.am
@@ -6,24 +6,24 @@
# $Id$
#
-AUTOMAKE_OPTIONS = foreign
+AUTOMAKE_OPTIONS = foreign 1.4
-PROJECT=c_user
+PROJECT = c_user
+EDITION = 1
include $(top_srcdir)/project.am
-COMMON_FILES=$(top_srcdir)/common/cpright.texi
+FILES = bsp.texi dirstat.texi example.texi glossary.texi preface.texi
-FILES= bsp.texi dirstat.texi example.texi glossary.texi preface.texi
+GENERATED_FILES = overview.texi concepts.texi datatypes.texi init.texi \
+ task.texi intr.texi clock.texi timer.texi sem.texi msg.texi event.texi \
+ signal.texi part.texi region.texi dpmem.texi io.texi fatal.texi \
+ schedule.texi rtmon.texi bsp.texi userext.texi conf.texi mp.texi
-GENERATED_FILES=overview.texi concepts.texi datatypes.texi init.texi \
- task.texi intr.texi clock.texi timer.texi sem.texi msg.texi \
- event.texi signal.texi part.texi region.texi \
- dpmem.texi io.texi fatal.texi schedule.texi rtmon.texi \
- bsp.texi userext.texi conf.texi mp.texi
+COMMON_FILES = $(top_srcdir)/common/setup.texi $(top_srcdir)/common/cpright.texi
info_TEXINFOS = c_user.texi
-c_user_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
+c_user_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
PNG_FILES = rtemsarc.png rtemspie.png states.png
@@ -31,137 +31,132 @@ EPS_IMAGES = rtemspie.eps states.eps
$(PROJECT).dvi: $(EPS_IMAGES)
PDF_IMAGES = rtemspie.pdf states.pdf
+CLEANFILES += $(PDF_IMAGES)
if USE_HTML
html_project_DATA += $(PNG_FILES)
endif
-#preface.texi: preface.t
-# $(BMENU) -p "Top" \
-# -u "Top" \
-# -n "Overview" $<
-
-overview.texi: overview.t
- $(BMENU) -p "Preface" \
+$(srcdir)/overview.texi: overview.t
+ $(BMENU2) -p "Preface" \
-u "Top" \
- -n "Key Concepts" $<
+ -n "Key Concepts" < $< > $@
-concepts.texi: concepts.t
- $(BMENU) -p "Overview Manual Organization" \
+$(srcdir)/concepts.texi: concepts.t
+ $(BMENU2) -p "Overview Manual Organization" \
-u "Top" \
- -n "RTEMS Data Types" $<
+ -n "RTEMS Data Types" < $< > $@
-datatypes.texi: datatypes.t
- $(BMENU) -p "Key Concepts Memory Management" \
+$(srcdir)/datatypes.texi: datatypes.t
+ $(BMENU2) -p "Key Concepts Memory Management" \
-u "Top" \
- -n "Initialization Manager" $<
+ -n "Initialization Manager" < $< > $@
-init.texi: init.t
- $(BMENU) -p "RTEMS Data Types List of Data Types" \
+$(srcdir)/init.texi: init.t
+ $(BMENU2) -p "RTEMS Data Types List of Data Types" \
-u "Top" \
- -n "Task Manager" $<
+ -n "Task Manager" < $< > $@
-task.texi: task.t
- $(BMENU) -p "Initialization Manager SHUTDOWN_EXECUTIVE - Shutdown RTEMS" \
+$(srcdir)/task.texi: task.t
+ $(BMENU2) -p "Initialization Manager SHUTDOWN_EXECUTIVE - Shutdown RTEMS" \
-u "Top" \
- -n "Interrupt Manager" $<
+ -n "Interrupt Manager" < $< > $@
-intr.texi: intr.t
- $(BMENU) -p "Task Manager TASK_VARIABLE_DELETE - Remove per task variable" \
+$(srcdir)/intr.texi: intr.t
+ $(BMENU2) -p "Task Manager TASK_VARIABLE_DELETE - Remove per task variable" \
-u "Top" \
- -n "Clock Manager" $<
+ -n "Clock Manager" < $< > $@
-clock.texi: clock.t
- $(BMENU) \
+$(srcdir)/clock.texi: clock.t
+ $(BMENU2) \
-p "Interrupt Manager INTERRUPT_IS_IN_PROGRESS - Is an ISR in Progress" \
-u "Top" \
- -n "Timer Manager" $<
+ -n "Timer Manager" < $< > $@
-timer.texi: timer.t
- $(BMENU) -p "Clock Manager CLOCK_TICK - Announce a clock tick" \
+$(srcdir)/timer.texi: timer.t
+ $(BMENU2) -p "Clock Manager CLOCK_TICK - Announce a clock tick" \
-u "Top" \
- -n "Semaphore Manager" $<
+ -n "Semaphore Manager" < $< > $@
-sem.texi: sem.t
- $(BMENU) -p "Timer Manager TIMER_RESET - Reset an interval timer" \
+$(srcdir)/sem.texi: sem.t
+ $(BMENU2) -p "Timer Manager TIMER_RESET - Reset an interval timer" \
-u "Top" \
- -n "Message Manager" $<
+ -n "Message Manager" < $< > $@
-msg.texi: msg.t
- $(BMENU) -p "Semaphore Manager SEMAPHORE_FLUSH - Unblock all tasks waiting on a semaphore" \
+$(srcdir)/msg.texi: msg.t
+ $(BMENU2) -p "Semaphore Manager SEMAPHORE_FLUSH - Unblock all tasks waiting on a semaphore" \
-u "Top" \
- -n "Event Manager" $<
+ -n "Event Manager" < $< > $@
-event.texi: event.t
- $(BMENU) \
+$(srcdir)/event.texi: event.t
+ $(BMENU2) \
-p "Message Manager MESSAGE_QUEUE_FLUSH - Flush all messages on a queue" \
-u "Top" \
- -n "Signal Manager" $<
+ -n "Signal Manager" < $< > $@
-signal.texi: signal.t
- $(BMENU) -p "Event Manager EVENT_RECEIVE - Receive event condition" \
+$(srcdir)/signal.texi: signal.t
+ $(BMENU2) -p "Event Manager EVENT_RECEIVE - Receive event condition" \
-u "Top" \
- -n "Partition Manager" $<
+ -n "Partition Manager" < $< > $@
-part.texi: part.t
- $(BMENU) -p "Signal Manager SIGNAL_SEND - Send signal set to a task" \
+$(srcdir)/part.texi: part.t
+ $(BMENU2) -p "Signal Manager SIGNAL_SEND - Send signal set to a task" \
-u "Top" \
- -n "Region Manager" $<
+ -n "Region Manager" < $< > $@
-region.texi: region.t
- $(BMENU) \
+$(srcdir)/region.texi: region.t
+ $(BMENU2) \
-p "Partition Manager PARTITION_RETURN_BUFFER - Return buffer to a partition" \
-u "Top" \
- -n "Dual-Ported Memory Manager" $<
+ -n "Dual-Ported Memory Manager" < $< > $@
-dpmem.texi: dpmem.t
- $(BMENU) \
+$(srcdir)/dpmem.texi: dpmem.t
+ $(BMENU2) \
-p "Region Manager REGION_GET_SEGMENT_SIZE - Obtain size of a segment" \
-u "Top" \
- -n "I/O Manager" $<
+ -n "I/O Manager" < $< > $@
-io.texi: io.t
- $(BMENU) -p "Dual-Ported Memory Manager PORT_INTERNAL_TO_EXTERNAL - Convert internal to external address" \
+$(srcdir)/io.texi: io.t
+ $(BMENU2) -p "Dual-Ported Memory Manager PORT_INTERNAL_TO_EXTERNAL - Convert internal to external address" \
-u "Top" \
- -n "Fatal Error Manager" $<
+ -n "Fatal Error Manager" < $< > $@
-fatal.texi: fatal.t
- $(BMENU) -p "I/O Manager IO_CONTROL - Special device services" \
+$(srcdir)/fatal.texi: fatal.t
+ $(BMENU2) -p "I/O Manager IO_CONTROL - Special device services" \
-u "Top" \
- -n "Scheduling Concepts" $<
+ -n "Scheduling Concepts" < $< > $@
-schedule.texi: schedule.t
- $(BMENU) \
+$(srcdir)/schedule.texi: schedule.t
+ $(BMENU2) \
-p "Fatal Error Manager FATAL_ERROR_OCCURRED - Invoke the fatal error handler" \
-u "Top" \
- -n "Rate Monotonic Manager" $<
+ -n "Rate Monotonic Manager" < $< > $@
-rtmon.texi: rtmon.t
- $(BMENU) -p "Scheduling Concepts Task State Transitions" \
+$(srcdir)/rtmon.texi: rtmon.t
+ $(BMENU2) -p "Scheduling Concepts Task State Transitions" \
-u "Top" \
- -n "Board Support Packages" $<
+ -n "Board Support Packages" < $< > $@
-bsp.texi: bsp.t
- $(BMENU) -p "Rate Monotonic Manager RATE_MONOTONIC_GET_STATUS - Obtain status information on period" \
+$(srcdir)/bsp.texi: bsp.t
+ $(BMENU2) -p "Rate Monotonic Manager RATE_MONOTONIC_GET_STATUS - Obtain status information on period" \
-u "Top" \
- -n "User Extensions Manager" $<
+ -n "User Extensions Manager" < $< > $@
-userext.texi: userext.t
- $(BMENU) -p "Board Support Packages Heterogeneous Systems" \
+$(srcdir)/userext.texi: userext.t
+ $(BMENU2) -p "Board Support Packages Heterogeneous Systems" \
-u "Top" \
- -n "Configuring a System" $<
+ -n "Configuring a System" < $< > $@
-conf.texi: conf.t
- $(BMENU) -p "User Extensions Manager EXTENSION_DELETE - Delete a extension set" \
+$(srcdir)/conf.texi: conf.t
+ $(BMENU2) -p "User Extensions Manager EXTENSION_DELETE - Delete a extension set" \
-u "Top" \
- -n "Multiprocessing Manager" $<
+ -n "Multiprocessing Manager" < $< > $@
-mp.texi: mp.t
- $(BMENU) -p "Configuring a System Sizing the RTEMS RAM Workspace" \
+$(srcdir)/mp.texi: mp.t
+ $(BMENU2) -p "Configuring a System Sizing the RTEMS RAM Workspace" \
-u "Top" \
- -n "Directive Status Codes" $<
+ -n "Directive Status Codes" < $< > $@
-noinst_DATA = \
-states.gif rtemspie.gif
+noinst_DATA = states.gif rtemspie.gif
EXTRA_DIST = *.t $(PNG_FILES) $(EPS_IMAGES) $(noinst_DATA)