summaryrefslogtreecommitdiffstats
path: root/doc/tools/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'doc/tools/configure.ac')
-rw-r--r--doc/tools/configure.ac28
1 files changed, 28 insertions, 0 deletions
diff --git a/doc/tools/configure.ac b/doc/tools/configure.ac
new file mode 100644
index 0000000000..b8a233279e
--- /dev/null
+++ b/doc/tools/configure.ac
@@ -0,0 +1,28 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl NOTE: This is a very coarse port to automake
+AC_PREREQ(2.59)
+
+AC_INIT([rtems-doc-tools],[_RTEMS_VERSION],[rtems-bugs@rtems.com])
+AC_CONFIG_SRCDIR([word-replace2])
+RTEMS_TOP([../..])
+
+AM_INIT_AUTOMAKE([no-define foreign 1.8])
+dnl Checks for programs.
+AC_PROG_CC
+
+dnl Checks for libraries.
+
+dnl Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS(limits.h)
+
+dnl Checks for typedefs, structures, and compiler characteristics.
+
+dnl Checks for library functions.
+AC_CHECK_FUNCS(strdup strstr)
+
+AC_CONFIG_FILES([Makefile
+bmenu/Makefile
+texi2www/Makefile
+])
+AC_OUTPUT