summaryrefslogtreecommitdiffstats
path: root/doc/supplements/sh/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/supplements/sh/Makefile.am')
-rw-r--r--doc/supplements/sh/Makefile.am84
1 files changed, 41 insertions, 43 deletions
diff --git a/doc/supplements/sh/Makefile.am b/doc/supplements/sh/Makefile.am
index 28338faaf2..962f7e66db 100644
--- a/doc/supplements/sh/Makefile.am
+++ b/doc/supplements/sh/Makefile.am
@@ -6,20 +6,21 @@
# $Id$
#
-AUTOMAKE_OPTIONS = foreign
+AUTOMAKE_OPTIONS = foreign 1.4
-PROJECT=sh
+PROJECT = sh
+EDITION = 1
include $(top_srcdir)/project.am
include $(top_srcdir)/supplements/supplement.am
-COMMON_FILES= $(top_srcdir)/common/cpright.texi $(top_builddir)/common/setup.texi
+GENERATED_FILES = cpumodel.texi callconv.texi memmodel.texi intr.texi \
+ fatalerr.texi bsp.texi cputable.texi wksheets.texi timing.texi \
+ timeBSP.texi
-GENERATED_FILES=\
- cpumodel.texi callconv.texi memmodel.texi intr.texi fatalerr.texi \
- bsp.texi cputable.texi wksheets.texi timing.texi timeBSP.texi
+COMMON_FILES = $(top_srcdir)/common/setup.texi $(top_srcdir)/common/cpright.texi
-FILES= preface.texi
+FILES = preface.texi
info_TEXINFOS = sh.texi
sh_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
@@ -27,64 +28,63 @@ sh_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
#
# Chapters which get automatic processing
#
-cpumodel.texi: cpumodel.t
- $(BMENU) -p "Preface" \
+
+$(srcdir)/cpumodel.texi: cpumodel.t
+ $(BMENU2) -p "Preface" \
-u "Top" \
- -n "Calling Conventions" $<
+ -n "Calling Conventions" < $< > $@
-callconv.texi: callconv.t
- $(BMENU) -p "CPU Model Dependent Features Another Optional Feature" \
+$(srcdir)/callconv.texi: callconv.t
+ $(BMENU2) -p "CPU Model Dependent Features Another Optional Feature" \
-u "Top" \
- -n "Memory Model" $<
+ -n "Memory Model" < $< > $@
-memmodel.texi: memmodel.t
- $(BMENU) -p "Calling Conventions User-Provided Routines" \
+$(srcdir)/memmodel.texi: memmodel.t
+ $(BMENU2) -p "Calling Conventions User-Provided Routines" \
-u "Top" \
- -n "Interrupt Processing" $<
+ -n "Interrupt Processing" < $< > $@
# Interrupt Chapter:
# 1. Replace Times and Sizes
# 2. Build Node Structure
-intr.texi: intr_NOTIMES.t BSP_TIMES
- ${REPLACE2} -p $(srcdir)/BSP_TIMES $(srcdir)/intr_NOTIMES.t intr.t
- $(BMENU) -p "Memory Model Flat Memory Model" \
+$(srcdir)/intr.texi: intr_NOTIMES.t BSP_TIMES
+ ${REPLACE2} -p $(srcdir)/BSP_TIMES $(srcdir)/intr_NOTIMES.t | \
+ $(BMENU2) -p "Memory Model Flat Memory Model" \
-u "Top" \
- -n "Default Fatal Error Processing" intr.t
-CLEANFILES += intr.t
+ -n "Default Fatal Error Processing" > $@
-fatalerr.texi: fatalerr.t
- $(BMENU) -p "Interrupt Processing Interrupt Stack" \
+$(srcdir)/fatalerr.texi: fatalerr.t
+ $(BMENU2) -p "Interrupt Processing Interrupt Stack" \
-u "Top" \
- -n "Board Support Packages" $<
+ -n "Board Support Packages" < $< > $@
-bsp.texi: bsp.t
- $(BMENU) -p "Default Fatal Error Processing Default Fatal Error Handler Operations" \
+$(srcdir)/bsp.texi: bsp.t
+ $(BMENU2) -p "Default Fatal Error Processing Default Fatal Error Handler Operations" \
-u "Top" \
- -n "Processor Dependent Information Table" $<
+ -n "Processor Dependent Information Table" < $< > $@
-cputable.texi: cputable.t
- $(BMENU) -p "Board Support Packages Processor Initialization" \
+$(srcdir)/cputable.texi: cputable.t
+ $(BMENU2) -p "Board Support Packages Processor Initialization" \
-u "Top" \
- -n "Memory Requirements" $<
+ -n "Memory Requirements" < $< > $@
# Worksheets Chapter:
# 1. Copy the Shared File
# 2. Replace Times and Sizes
# 3. Build Node Structure
-wksheets.texi: $(top_srcdir)/common/wksheets.t BSP_TIMES
+$(srcdir)/wksheets.texi: $(top_srcdir)/common/wksheets.t BSP_TIMES
${REPLACE2} -p $(srcdir)/BSP_TIMES \
- $(top_srcdir)/common/wksheets.t wksheets.t
- $(BMENU) -p "Processor Dependent Information Table CPU Dependent Information Table" \
+ $(top_srcdir)/common/wksheets.t | \
+ $(BMENU2) -p "Processor Dependent Information Table CPU Dependent Information Table" \
-u "Top" \
- -n "Timing Specification" wksheets.t
-CLEANFILES += wksheets.t
+ -n "Timing Specification" > $@
# Timing Specification Chapter:
# 1. Copy the Shared File
# 3. Build Node Structure
-timing.texi: $(top_srcdir)/common/timing.t
+$(srcdir)/timing.texi: $(top_srcdir)/common/timing.t
$(BMENU2) -p "Memory Requirements RTEMS RAM Workspace Worksheet" \
-u "Top" \
-n "BSP_FOR_TIMES Timing Data" < $< > $@
@@ -94,18 +94,16 @@ timing.texi: $(top_srcdir)/common/timing.t
# 2. Replace Times and Sizes
# 3. Build Node Structure
-timeBSP.texi: $(top_srcdir)/common/timetbl.t timeBSP.t
+$(srcdir)/timeBSP.texi: $(top_srcdir)/common/timetbl.t timeBSP.t
cat timeBSP.t $(top_srcdir)/common/timetbl.t >timeBSP_.t
@echo >>timeBSP_.t
@echo "@tex" >>timeBSP_.t
@echo "\\global\\advance \\smallskipamount by 4pt" >>timeBSP_.t
@echo "@end tex" >>timeBSP_.t
- ${REPLACE2} -p BSP_TIMES timeBSP_.t timeBSP_.t
- $(BMENU) -p "Timing Specification Terminology" \
+ ${REPLACE2} -p BSP_TIMES timeBSP_.t | \
+ $(BMENU2) -p "Timing Specification Terminology" \
-u "Top" \
- -n "Command and Variable Index" timeBSP_.t
- mv timeBSP_.texi timeBSP.texi
-CLEANFILES += timeBSP_.t timeBSP_.texi
-
+ -n "Command and Variable Index" > $@
+CLEANFILES += timeBSP_.t
EXTRA_DIST = BSP_TIMES *.t