summaryrefslogtreecommitdiffstats
path: root/doc/supplements/powerpc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/supplements/powerpc/Makefile.am')
-rw-r--r--doc/supplements/powerpc/Makefile.am96
1 files changed, 45 insertions, 51 deletions
diff --git a/doc/supplements/powerpc/Makefile.am b/doc/supplements/powerpc/Makefile.am
index 37b6bc324b..de1b709db0 100644
--- a/doc/supplements/powerpc/Makefile.am
+++ b/doc/supplements/powerpc/Makefile.am
@@ -6,20 +6,20 @@
# $Id$
#
-AUTOMAKE_OPTIONS = foreign
+AUTOMAKE_OPTIONS = foreign 1.4
-PROJECT=powerpc
+PROJECT = powerpc
+EDITION = 1
include $(top_srcdir)/project.am
include $(top_srcdir)/supplements/supplement.am
-COMMON_FILES=$(top_srcdir)/common/cpright.texi $(top_builddir)/common/setup.texi
+GENERATED_FILES = cpumodel.texi callconv.texi memmodel.texi intr.texi \
+ fatalerr.texi bsp.texi cputable.texi timing.texi wksheets.texi \
+ timePSIM.texi timeDMV177.texi
+COMMON_FILES = $(top_srcdir)/common/setup.texi $(top_srcdir)/common/cpright.texi
-GENERATED_FILES=\
- cpumodel.texi callconv.texi memmodel.texi intr.texi fatalerr.texi \
- bsp.texi cputable.texi timing.texi wksheets.texi timePSIM.texi timeDMV177.texi
-
-FILES= preface.texi
+FILES = preface.texi
info_TEXINFOS = powerpc.texi
powerpc_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
@@ -28,63 +28,61 @@ powerpc_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
# Chapters which get automatic processing
#
-cpumodel.texi: cpumodel.t
- $(BMENU) -p "Preface" \
+$(srcdir)/cpumodel.texi: cpumodel.t
+ $(BMENU2) -p "Preface" \
-u "Top" \
- -n "Calling Conventions" $<
+ -n "Calling Conventions" < $< > $@
-callconv.texi: callconv.t
- $(BMENU) -p "CPU Model Dependent Features Low Power Model" \
+$(srcdir)/callconv.texi: callconv.t
+ $(BMENU2) -p "CPU Model Dependent Features Low Power Model" \
-u "Top" \
- -n "Memory Model" $<
+ -n "Memory Model" < $< > $@
-memmodel.texi: memmodel.t
- $(BMENU) -p "Calling Conventions User-Provided Routines" \
+$(srcdir)/memmodel.texi: memmodel.t
+ $(BMENU2) -p "Calling Conventions User-Provided Routines" \
-u "Top" \
- -n "Interrupt Processing" $<
+ -n "Interrupt Processing" < $< > $@
# Interrupt Chapter:
# 1. Replace Times and Sizes
# 2. Build Node Structure
-intr.texi: intr_NOTIMES.t PSIM_TIMES
- ${REPLACE2} -p $(srcdir)/PSIM_TIMES $(srcdir)/intr_NOTIMES.t intr.t
- $(BMENU) -p "Memory Model Flat Memory Model" \
+$(srcdir)/intr.texi: intr_NOTIMES.t PSIM_TIMES
+ ${REPLACE2} -p $(srcdir)/PSIM_TIMES $(srcdir)/intr_NOTIMES.t | \
+ $(BMENU2) -p "Memory Model Flat Memory Model" \
-u "Top" \
- -n "Default Fatal Error Processing" intr.t
-CLEANFILES += intr.t
+ -n "Default Fatal Error Processing" > $@
-fatalerr.texi: fatalerr.t
- $(BMENU) -p "Interrupt Processing Interrupt Stack" \
+$(srcdir)/fatalerr.texi: fatalerr.t
+ $(BMENU2) -p "Interrupt Processing Interrupt Stack" \
-u "Top" \
- -n "Board Support Packages" $<
+ -n "Board Support Packages" < $< > $@
-bsp.texi: bsp.t
- $(BMENU) -p "Default Fatal Error Processing Default Fatal Error Handler Operations" \
+$(srcdir)/bsp.texi: bsp.t
+ $(BMENU2) -p "Default Fatal Error Processing Default Fatal Error Handler Operations" \
-u "Top" \
- -n "Processor Dependent Information Table" $<
+ -n "Processor Dependent Information Table" < $< > $@
-cputable.texi: cputable.t
- $(BMENU) -p "Board Support Packages Processor Initialization" \
+$(srcdir)/cputable.texi: cputable.t
+ $(BMENU2) -p "Board Support Packages Processor Initialization" \
-u "Top" \
- -n "Memory Requirements" $<
+ -n "Memory Requirements" < $< > $@
# Worksheets Chapter:
# 1. Obtain the Shared File
# 2. Replace Times and Sizes
# 3. Build Node Structure
-wksheets.texi: $(top_srcdir)/common/wksheets.t PSIM_TIMES
+$(srcdir)/wksheets.texi: $(top_srcdir)/common/wksheets.t PSIM_TIMES
${REPLACE2} -p $(srcdir)/PSIM_TIMES \
- $(top_srcdir)/common/wksheets.t wksheets.t
- $(BMENU) -p "Processor Dependent Information Table CPU Dependent Information Table" \
+ $(top_srcdir)/common/wksheets.t | \
+ $(BMENU2) -p "Processor Dependent Information Table CPU Dependent Information Table" \
-u "Top" \
- -n "Timing Specification" wksheets.t
-CLEANFILES += wksheets.t
+ -n "Timing Specification" > $@
# Timing Specification Chapter:
# 1. Copy the Shared File
# 3. Build Node Structure
-timing.texi: $(top_srcdir)/common/timing.t
+$(srcdir)/timing.texi: $(top_srcdir)/common/timing.t
$(BMENU2) -p "Memory Requirements RTEMS RAM Workspace Worksheet" \
-u "Top" \
-n "PSIM Timing Data" < $< > $@
@@ -94,37 +92,33 @@ timing.texi: $(top_srcdir)/common/timing.t
# 2. Replace Times and Sizes
# 3. Build Node Structure
-timePSIM.texi: $(top_srcdir)/common/timetbl.t timePSIM.t
+$(srcdir)/timePSIM.texi: $(top_srcdir)/common/timetbl.t timePSIM.t
cat timePSIM.t $(top_srcdir)/common/timetbl.t >timePSIM_.t
@echo >>timePSIM_.t
@echo "@tex" >>timePSIM_.t
@echo "\\global\\advance \\smallskipamount by 4pt" >>timePSIM_.t
@echo "@end tex" >>timePSIM_.t
- ${REPLACE2} -p PSIM_TIMES timePSIM_.t timePSIM_.t
- $(BMENU) -p "Timing Specification Terminology" \
+ ${REPLACE2} -p PSIM_TIMES timePSIM_.t | \
+ $(BMENU2) -p "Timing Specification Terminology" \
-u "Top" \
- -n "DMV177 Timing Data" timePSIM_.t
- mv timePSIM_.texi timePSIM.texi
-CLEANFILES += timePSIM_.t timePSIM_.texi
-
+ -n "DMV177 Timing Data" > $@
+CLEANFILES += timePSIM_.t
# Timing Data for DMV177 BSP Chapter:
# 1. Copy the Shared File
# 2. Replace Times and Sizes
# 3. Build Node Structure
-timeDMV177.texi: $(top_srcdir)/common/timetbl.t timeDMV177.t
+$(srcdir)/timeDMV177.texi: $(top_srcdir)/common/timetbl.t timeDMV177.t
cat timeDMV177.t $(top_srcdir)/common/timetbl.t >timeDMV177_.t
@echo >>timeDMV177_.t
@echo "@tex" >>timeDMV177_.t
@echo "\\global\\advance \\smallskipamount by 4pt" >>timeDMV177_.t
@echo "@end tex" >>timeDMV177_.t
- ${REPLACE2} -p DMV177_TIMES timeDMV177_.t timeDMV177_.t
- $(BMENU) -p "PSIM Timing Data Rate Monotonic Manager" \
+ ${REPLACE2} -p DMV177_TIMES timeDMV177_.t | \
+ $(BMENU2) -p "PSIM Timing Data Rate Monotonic Manager" \
-u "Top" \
- -n "Command and Variable Index" timeDMV177_.t
- mv timeDMV177_.texi timeDMV177.texi
-CLEANFILES += timeDMV177_.t timeDMV177_.texi
-
+ -n "Command and Variable Index" > $@
+CLEANFILES += timeDMV177_.t
EXTRA_DIST = DMV177_TIMES PSIM_TIMES *.t