summaryrefslogtreecommitdiffstats
path: root/doc/supplements/powerpc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--doc/supplements/powerpc/Makefile.am22
1 files changed, 11 insertions, 11 deletions
diff --git a/doc/supplements/powerpc/Makefile.am b/doc/supplements/powerpc/Makefile.am
index 62c029d7a4..9184893c93 100644
--- a/doc/supplements/powerpc/Makefile.am
+++ b/doc/supplements/powerpc/Makefile.am
@@ -28,17 +28,17 @@ powerpc_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
# Chapters which get automatic processing
#
-$(srcdir)/cpumodel.texi: cpumodel.t
+cpumodel.texi: cpumodel.t
$(BMENU2) -p "Preface" \
-u "Top" \
-n "Calling Conventions" < $< > $@
-$(srcdir)/callconv.texi: callconv.t
+callconv.texi: callconv.t
$(BMENU2) -p "CPU Model Dependent Features Low Power Model" \
-u "Top" \
-n "Memory Model" < $< > $@
-$(srcdir)/memmodel.texi: memmodel.t
+memmodel.texi: memmodel.t
$(BMENU2) -p "Calling Conventions User-Provided Routines" \
-u "Top" \
-n "Interrupt Processing" < $< > $@
@@ -46,23 +46,23 @@ $(srcdir)/memmodel.texi: memmodel.t
# Interrupt Chapter:
# 1. Replace Times and Sizes
# 2. Build Node Structure
-$(srcdir)/intr.texi: intr_NOTIMES.t PSIM_TIMES
+intr.texi: intr_NOTIMES.t PSIM_TIMES
${REPLACE2} -p $(srcdir)/PSIM_TIMES $(srcdir)/intr_NOTIMES.t | \
$(BMENU2) -p "Memory Model Flat Memory Model" \
-u "Top" \
-n "Default Fatal Error Processing" > $@
-$(srcdir)/fatalerr.texi: fatalerr.t
+fatalerr.texi: fatalerr.t
$(BMENU2) -p "Interrupt Processing Interrupt Stack" \
-u "Top" \
-n "Board Support Packages" < $< > $@
-$(srcdir)/bsp.texi: bsp.t
+bsp.texi: bsp.t
$(BMENU2) -p "Default Fatal Error Processing Default Fatal Error Handler Operations" \
-u "Top" \
-n "Processor Dependent Information Table" < $< > $@
-$(srcdir)/cputable.texi: cputable.t
+cputable.texi: cputable.t
$(BMENU2) -p "Board Support Packages Processor Initialization" \
-u "Top" \
-n "Memory Requirements" < $< > $@
@@ -72,7 +72,7 @@ $(srcdir)/cputable.texi: cputable.t
# 2. Replace Times and Sizes
# 3. Build Node Structure
-$(srcdir)/wksheets.texi: $(top_srcdir)/common/wksheets.t PSIM_TIMES
+wksheets.texi: $(top_srcdir)/common/wksheets.t PSIM_TIMES
${REPLACE2} -p $(srcdir)/PSIM_TIMES \
$(top_srcdir)/common/wksheets.t | \
$(BMENU2) -p "Processor Dependent Information Table CPU Dependent Information Table" \
@@ -82,7 +82,7 @@ $(srcdir)/wksheets.texi: $(top_srcdir)/common/wksheets.t PSIM_TIMES
# Timing Specification Chapter:
# 1. Copy the Shared File
# 3. Build Node Structure
-$(srcdir)/timing.texi: $(top_srcdir)/common/timing.t
+timing.texi: $(top_srcdir)/common/timing.t
$(BMENU2) -p "Memory Requirements RTEMS RAM Workspace Worksheet" \
-u "Top" \
-n "PSIM Timing Data" < $< > $@
@@ -92,7 +92,7 @@ $(srcdir)/timing.texi: $(top_srcdir)/common/timing.t
# 2. Replace Times and Sizes
# 3. Build Node Structure
-$(srcdir)/timePSIM.texi: $(top_srcdir)/common/timetbl.t timePSIM.t
+timePSIM.texi: $(top_srcdir)/common/timetbl.t timePSIM.t
cat $(srcdir)/timePSIM.t $(top_srcdir)/common/timetbl.t >timePSIM_.t
@echo >>timePSIM_.t
@echo "@tex" >>timePSIM_.t
@@ -109,7 +109,7 @@ CLEANFILES += timePSIM_.t timeDMV177_.t
# 2. Replace Times and Sizes
# 3. Build Node Structure
-$(srcdir)/timeDMV177.texi: $(top_srcdir)/common/timetbl.t timeDMV177.t
+timeDMV177.texi: $(top_srcdir)/common/timetbl.t timeDMV177.t
cat $(srcdir)/timeDMV177.t $(top_srcdir)/common/timetbl.t >timeDMV177_.t
@echo >>timeDMV177_.t
@echo "@tex" >>timeDMV177_.t