summaryrefslogtreecommitdiffstats
path: root/doc/supplements/mips64orion/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/supplements/mips64orion/Makefile.am')
-rw-r--r--doc/supplements/mips64orion/Makefile.am114
1 files changed, 114 insertions, 0 deletions
diff --git a/doc/supplements/mips64orion/Makefile.am b/doc/supplements/mips64orion/Makefile.am
new file mode 100644
index 0000000000..cc30fbb2cc
--- /dev/null
+++ b/doc/supplements/mips64orion/Makefile.am
@@ -0,0 +1,114 @@
+#
+# COPYRIGHT (c) 1988-1999.
+# On-Line Applications Research Corporation (OAR).
+# All rights reserved.
+#
+# $Id$
+#
+
+AUTOMAKE_OPTIONS = foreign
+
+PROJECT=mips64orion
+
+include $(top_srcdir)/project.am
+include $(top_srcdir)/supplements/supplement.am
+
+COMMON_FILES=$(top_srcdir)/common/cpright.texi $(top_builddir)/common/setup.texi
+
+GENERATED_FILES=\
+ cpumodel.texi callconv.texi memmodel.texi intr.texi fatalerr.texi \
+ bsp.texi cputable.texi wksheets.texi timing.texi timeBSP.texi
+
+FILES= preface.texi
+
+info_TEXINFOS = mips64orion.texi
+mips64orion_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
+
+#
+# Chapters which get automatic processing
+#
+cpumodel.texi: cpumodel.t
+ $(BMENU) -p "Preface" \
+ -u "Top" \
+ -n "Calling Conventions" $<
+
+callconv.texi: callconv.t
+ $(BMENU) -p "CPU Model Dependent Features Another Optional Feature" \
+ -u "Top" \
+ -n "Memory Model" $<
+
+memmodel.texi: memmodel.t
+ $(BMENU) -p "Calling Conventions User-Provided Routines" \
+ -u "Top" \
+ -n "Interrupt Processing" $<
+
+# Interrupt Chapter:
+# 1. Replace Times and Sizes
+# 2. Build Node Structure
+intr.texi: intr_NOTIMES.t BSP_TIMES
+ ${REPLACE2} -p $(srcdir)/BSP_TIMES $(srcdir)/intr_NOTIMES.t intr.t
+ $(BMENU) -p "Memory Model Flat Memory Model" \
+ -u "Top" \
+ -n "Default Fatal Error Processing" intr.t
+CLEANFILES += intr.t
+
+fatalerr.texi: fatalerr.t
+ $(BMENU) -p "Interrupt Processing Interrupt Stack" \
+ -u "Top" \
+ -n "Board Support Packages" $<
+
+bsp.texi: bsp.t
+ $(BMENU) -p "Default Fatal Error Processing Default Fatal Error Handler Operations" \
+ -u "Top" \
+ -n "Processor Dependent Information Table" $<
+
+cputable.texi: cputable.t
+ $(BMENU) -p "Board Support Packages Processor Initialization" \
+ -u "Top" \
+ -n "Memory Requirements" $<
+
+# Worksheets Chapter:
+# 1. Copy the Shared File
+# 2. Replace Times and Sizes
+# 3. Build Node Structure
+
+wksheets.texi: $(top_srcdir)/common/wksheets.t BSP_TIMES
+ ${REPLACE2} -p $(srcdir)/BSP_TIMES \
+ $(top_srcdir)/common/wksheets.t wksheets.t
+ $(BMENU) -p "Processor Dependent Information Table CPU Dependent Information Table" \
+ -u "Top" \
+ -n "Timing Specification" wksheets.t
+CLEANFILES += wksheets.t
+
+# Timing Specification Chapter:
+# 1. Copy the Shared File
+# 3. Build Node Structure
+
+timing.texi: $(top_srcdir)/common/timing.t
+ cp $(top_srcdir)/common/timing.t timing.t
+ $(BMENU) -p "Memory Requirements RTEMS RAM Workspace Worksheet" \
+ -u "Top" \
+ -n "BSP_FOR_TIMES Timing Data" timing.t
+CLEANFILES += timing.t
+
+# Timing Data for BSP Chapter:
+# 1. Copy the Shared File
+# 2. Replace Times and Sizes
+# 3. Build Node Structure
+
+timeBSP_.t: $(top_srcdir)/common/timetbl.t timeBSP.t
+ cat timeBSP.t $(top_srcdir)/common/timetbl.t >timeBSP_.t
+ @echo >>timeBSP_.t
+ @echo "@tex" >>timeBSP_.t
+ @echo "\\global\\advance \\smallskipamount by 4pt" >>timeBSP_.t
+ @echo "@end tex" >>timeBSP_.t
+ ${REPLACE} -p BSP_TIMES timeBSP_.t
+ mv timeBSP_.t.fixed timeBSP_.t
+
+timeBSP.texi: timeBSP_.t
+ $(BMENU) -p "Timing Specification Terminology" \
+ -u "Top" \
+ -n "Command and Variable Index" timeBSP_.t
+ mv timeBSP_.texi timeBSP.texi
+
+EXTRA_DIST = BSP_TIMES *.t