summaryrefslogtreecommitdiffstats
path: root/doc/supplements/m68k/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--doc/supplements/m68k/Makefile.am20
1 files changed, 10 insertions, 10 deletions
diff --git a/doc/supplements/m68k/Makefile.am b/doc/supplements/m68k/Makefile.am
index 1e75423686..e4ac248b34 100644
--- a/doc/supplements/m68k/Makefile.am
+++ b/doc/supplements/m68k/Makefile.am
@@ -29,17 +29,17 @@ m68k_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
# Chapters which get automatic processing
#
-$(srcdir)/cpumodel.texi: cpumodel.t
+cpumodel.texi: cpumodel.t
$(BMENU2) -p "Preface" \
-u "Top" \
-n "Calling Conventions" < $< > $@
-$(srcdir)/callconv.texi: callconv.t
+callconv.texi: callconv.t
$(BMENU2) -p "CPU Model Dependent Features Extend Byte to Long Instruction" \
-u "Top" \
-n "Memory Model" < $< > $@
-$(srcdir)/memmodel.texi: memmodel.t
+memmodel.texi: memmodel.t
$(BMENU2) -p "Calling Conventions User-Provided Routines" \
-u "Top" \
-n "Interrupt Processing" < $< > $@
@@ -47,23 +47,23 @@ $(srcdir)/memmodel.texi: memmodel.t
# Interrupt Chapter:
# 1. Replace Times and Sizes
# 2. Build Node Structure
-$(srcdir)/intr.texi: intr_NOTIMES.t MVME136_TIMES
+intr.texi: intr_NOTIMES.t MVME136_TIMES
${REPLACE2} -p $(srcdir)/MVME136_TIMES $(srcdir)/intr_NOTIMES.t | \
$(BMENU2) -p "Memory Model Flat Memory Model" \
-u "Top" \
-n "Default Fatal Error Processing" > $@
-$(srcdir)/fatalerr.texi: fatalerr.t
+fatalerr.texi: fatalerr.t
$(BMENU2) -p "Interrupt Processing Interrupt Stack" \
-u "Top" \
-n "Board Support Packages" < $< > $@
-$(srcdir)/bsp.texi: bsp.t
+bsp.texi: bsp.t
$(BMENU2) -p "Default Fatal Error Processing Default Fatal Error Handler Operations" \
-u "Top" \
-n "Processor Dependent Information Table" < $< > $@
-$(srcdir)/cputable.texi: cputable.t
+cputable.texi: cputable.t
$(BMENU2) -p "Board Support Packages Processor Initialization" \
-u "Top" \
-n "Memory Requirements" < $< > $@
@@ -73,7 +73,7 @@ $(srcdir)/cputable.texi: cputable.t
# 2. Replace Times and Sizes
# 3. Build Node Structure
-$(srcdir)/wksheets.texi: $(top_srcdir)/common/wksheets.t MVME136_TIMES
+wksheets.texi: $(top_srcdir)/common/wksheets.t MVME136_TIMES
${REPLACE2} -p $(srcdir)/MVME136_TIMES \
$(top_srcdir)/common/wksheets.t | \
$(BMENU2) -p "Processor Dependent Information Table CPU Dependent Information Table" \
@@ -84,7 +84,7 @@ $(srcdir)/wksheets.texi: $(top_srcdir)/common/wksheets.t MVME136_TIMES
# 1. Copy the Shared File
# 3. Build Node Structure
-$(srcdir)/timing.texi: $(top_srcdir)/common/timing.t
+timing.texi: $(top_srcdir)/common/timing.t
$(BMENU2) -p "Memory Requirements RTEMS RAM Workspace Worksheet" \
-u "Top" \
-n "MVME136 Timing Data" < $< > $@
@@ -94,7 +94,7 @@ $(srcdir)/timing.texi: $(top_srcdir)/common/timing.t
# 2. Replace Times and Sizes
# 3. Build Node Structure
-$(srcdir)/timeMVME136.texi: $(top_srcdir)/common/timetbl.t timeMVME136.t
+timeMVME136.texi: $(top_srcdir)/common/timetbl.t timeMVME136.t
cat $(srcdir)/timeMVME136.t $(top_srcdir)/common/timetbl.t >timeMVME136_.t
@echo >>timeMVME136_.t
@echo "@tex" >>timeMVME136_.t