summaryrefslogtreecommitdiffstats
path: root/doc/supplements/i386/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/supplements/i386/Makefile.am')
-rw-r--r--doc/supplements/i386/Makefile.am84
1 files changed, 41 insertions, 43 deletions
diff --git a/doc/supplements/i386/Makefile.am b/doc/supplements/i386/Makefile.am
index f3f16baac4..60f24391cc 100644
--- a/doc/supplements/i386/Makefile.am
+++ b/doc/supplements/i386/Makefile.am
@@ -6,86 +6,85 @@
# $Id$
#
-AUTOMAKE_OPTIONS = foreign
+AUTOMAKE_OPTIONS = foreign 1.4
-PROJECT=i386
+PROJECT = i386
+EDITION = 1
include $(top_srcdir)/project.am
include $(top_srcdir)/supplements/supplement.am
-COMMON_FILES=$(top_srcdir)/common/cpright.texi $(top_builddir)/common/setup.texi
+GENERATED_FILES = cpumodel.texi callconv.texi memmodel.texi intr.texi \
+ fatalerr.texi bsp.texi cputable.texi timing.texi wksheets.texi \
+ timeFORCE386.texi
-GENERATED_FILES=\
- cpumodel.texi callconv.texi memmodel.texi intr.texi fatalerr.texi \
- bsp.texi cputable.texi timing.texi wksheets.texi timeFORCE386.texi
+COMMON_FILES = $(top_srcdir)/common/setup.texi $(top_srcdir)/common/cpright.texi
-FILES= preface.texi
+FILES = preface.texi
info_TEXINFOS = i386.texi
-i386_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
+i386_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
#
# Chapters which get automatic processing
#
-cpumodel.texi: cpumodel.t
- $(BMENU) -p "Preface" \
+$(srcdir)/cpumodel.texi: cpumodel.t
+ $(BMENU2) -p "Preface" \
-u "Top" \
- -n "Calling Conventions" $<
+ -n "Calling Conventions" < $< > $@
-callconv.texi: callconv.t
- $(BMENU) -p "CPU Model Dependent Features Floating Point Unit" \
+$(srcdir)/callconv.texi: callconv.t
+ $(BMENU2) -p "CPU Model Dependent Features Floating Point Unit" \
-u "Top" \
- -n "Memory Model" $<
+ -n "Memory Model" < $< > $@
-memmodel.texi: memmodel.t
- $(BMENU) -p "Calling Conventions User-Provided Routines" \
+$(srcdir)/memmodel.texi: memmodel.t
+ $(BMENU2) -p "Calling Conventions User-Provided Routines" \
-u "Top" \
- -n "Interrupt Processing" $<
+ -n "Interrupt Processing" < $< > $@
# Interrupt Chapter:
# 1. Replace Times and Sizes
# 2. Build Node Structure
-intr.texi: intr_NOTIMES.t FORCE386_TIMES
- ${REPLACE2} -p $(srcdir)/FORCE386_TIMES $(srcdir)/intr_NOTIMES.t intr.t
- $(BMENU) -p "Memory Model Flat Memory Model" \
+$(srcdir)/intr.texi: intr_NOTIMES.t FORCE386_TIMES
+ ${REPLACE2} -p $(srcdir)/FORCE386_TIMES $(srcdir)/intr_NOTIMES.t | \
+ $(BMENU2) -p "Memory Model Flat Memory Model" \
-u "Top" \
- -n "Default Fatal Error Processing" intr.t
-CLEANFILES += intr.t
+ -n "Default Fatal Error Processing" > $@
-fatalerr.texi: fatalerr.t
- $(BMENU) -p "Interrupt Processing Interrupt Stack" \
+$(srcdir)/fatalerr.texi: fatalerr.t
+ $(BMENU2) -p "Interrupt Processing Interrupt Stack" \
-u "Top" \
- -n "Board Support Packages" $<
+ -n "Board Support Packages" < $< > $@
-bsp.texi: bsp.t
- $(BMENU) -p "Default Fatal Error Processing Default Fatal Error Handler Operations" \
+$(srcdir)/bsp.texi: bsp.t
+ $(BMENU2) -p "Default Fatal Error Processing Default Fatal Error Handler Operations" \
-u "Top" \
- -n "Processor Dependent Information Table" $<
+ -n "Processor Dependent Information Table" < $< > $@
-cputable.texi: cputable.t
- $(BMENU) -p "Board Support Packages Processor Initialization" \
+$(srcdir)/cputable.texi: cputable.t
+ $(BMENU2) -p "Board Support Packages Processor Initialization" \
-u "Top" \
- -n "Memory Requirements" $<
+ -n "Memory Requirements" < $< > $@
# Worksheets Chapter:
# 1. Obtain the Shared File
# 2. Replace Times and Sizes
# 3. Build Node Structure
-wksheets.texi: $(top_srcdir)/common/wksheets.t FORCE386_TIMES
+$(srcdir)/wksheets.texi: $(top_srcdir)/common/wksheets.t FORCE386_TIMES
${REPLACE2} -p $(srcdir)/FORCE386_TIMES \
- $(top_srcdir)/common/wksheets.t wksheets.t
- $(BMENU) -p "Processor Dependent Information Table CPU Dependent Information Table" \
+ $(top_srcdir)/common/wksheets.t | \
+ $(BMENU2) -p "Processor Dependent Information Table CPU Dependent Information Table" \
-u "Top" \
- -n "Timing Specification" wksheets.t
-CLEANFILES += wksheets.t
+ -n "Timing Specification" > $@
# Timing Specification Chapter:
# 1. Copy the Shared File
# 3. Build Node Structure
-timing.texi: $(top_srcdir)/common/timing.t
+$(srcdir)/timing.texi: $(top_srcdir)/common/timing.t
$(BMENU2) -p "Memory Requirements RTEMS RAM Workspace Worksheet" \
-u "Top" \
-n "CPU386 Timing Data" < $< > $@
@@ -95,17 +94,16 @@ timing.texi: $(top_srcdir)/common/timing.t
# 2. Replace Times and Sizes
# 3. Build Node Structure
-timeFORCE386.texi: $(top_srcdir)/common/timetbl.t timeFORCE386.t
+$(srcdir)/timeFORCE386.texi: $(top_srcdir)/common/timetbl.t timeFORCE386.t
cat timeFORCE386.t $(top_srcdir)/common/timetbl.t >timeFORCE386_.t
@echo >>timeFORCE386_.t
@echo "@tex" >>timeFORCE386_.t
@echo "\\global\\advance \\smallskipamount by 4pt" >>timeFORCE386_.t
@echo "@end tex" >>timeFORCE386_.t
- ${REPLACE2} -p FORCE386_TIMES timeFORCE386_.t timeFORCE386_.t
- $(BMENU) -p "Timing Specification Terminology" \
+ ${REPLACE2} -p FORCE386_TIMES timeFORCE386_.t | \
+ $(BMENU2) -p "Timing Specification Terminology" \
-u "Top" \
- -n "Command and Variable Index" timeFORCE386_.t
- mv timeFORCE386_.texi timeFORCE386.texi
-CLEANFILES += timeFORCE386_.t timeFORCE386_.texi
+ -n "Command and Variable Index" > $@
+CLEANFILES += timeFORCE386_.t
EXTRA_DIST = FORCE386_TIMES *.t