summaryrefslogtreecommitdiffstats
path: root/doc/started/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/started/Makefile.am')
-rw-r--r--doc/started/Makefile.am28
1 files changed, 11 insertions, 17 deletions
diff --git a/doc/started/Makefile.am b/doc/started/Makefile.am
index 762e5a4231..5bc093d6b6 100644
--- a/doc/started/Makefile.am
+++ b/doc/started/Makefile.am
@@ -1,5 +1,5 @@
#
-# COPYRIGHT (c) 1988-2002.
+# COPYRIGHT (c) 1988-2010.
# On-Line Applications Research Corporation (OAR).
# All rights reserved.
#
@@ -21,42 +21,43 @@ FILES =
info_TEXINFOS = started.texi
started_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
-intro.texi: intro.t tversions.texi
+intro.texi: intro.t
$(BMENU2) -c -p "Top" \
-u "Top" \
-n "Requirements" < $< > $@
-require.texi: require.t tversions.texi
+require.texi: require.t
$(BMENU2) -c -p "GCC Mailing Lists" \
-u "Top" \
-n "Prebuilt Toolset Executables" < $< > $@
-binaries.texi: binaries.t tversions.texi
- $(BMENU2) -c -p "Archive and Build Directory Format" \
+binaries.texi: binaries.t
+ $(BMENU2) -c \
+ -p "GNU/Linux Distrobutions using Debian Packaging Format" \
-u "Top" \
-n "Building the GNU Cross Compiler Toolset" < $< > $@
-buildc.texi: buildc.t tversions.texi
+buildc.texi: buildc.t
$(BMENU2) -c -p "Removing Zipped Tar Files" \
-u "Top" \
-n "Building RTEMS" < $< > $@
-buildrt.texi: buildrt.t tversions.texi
+buildrt.texi: buildrt.t
$(BMENU2) -c -p "Error Messages Indicating Configuration Problems" \
-u "Top" \
-n "Building the Sample Applications" < $< > $@
-sample.texi: sample.t tversions.texi
+sample.texi: sample.t
$(BMENU2) -c -p "Using the RTEMS configure Script Directly" \
-u "Top" \
-n "Where To Go From Here" < $< > $@
-nextstep.texi: nextstep.t tversions.texi
+nextstep.texi: nextstep.t
$(BMENU2) -c -p "More Information on RTEMS Application Makefiles" \
-u "Top" \
-n "Using MS-Windows as a Development Host" < $< > $@
-nt.texi: nt.t tversions.texi
+nt.texi: nt.t
$(BMENU2) -c -p "Writing an Application" \
-u "Top" \
-n "" < $< > $@
@@ -82,11 +83,4 @@ PICTURES = pictures/bit_ada.jpg pictures/bit_ada.vsd pictures/bit_c.jpg \
EXTRA_DIST += $(PICTURES)
-tversions.texi: tversions.texi.in tversions.sed
- sed -f tversions.sed $(srcdir)/tversions.texi.in > tversions.texi
-CLEANFILES += tversions.texi
-
-EXTRA_DIST += tversions.texi.in
-DISTCLEANFILES = tversions.sed
-
CLEANFILES += started.info started.info-?