summaryrefslogtreecommitdiffstats
path: root/doc/rtems_gdb/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/rtems_gdb/Makefile.am')
-rw-r--r--doc/rtems_gdb/Makefile.am61
1 files changed, 61 insertions, 0 deletions
diff --git a/doc/rtems_gdb/Makefile.am b/doc/rtems_gdb/Makefile.am
new file mode 100644
index 0000000000..7471f6224f
--- /dev/null
+++ b/doc/rtems_gdb/Makefile.am
@@ -0,0 +1,61 @@
+#
+# COPYRIGHT (c) 1988-2002.
+# On-Line Applications Research Corporation (OAR).
+# All rights reserved.
+#
+# $Id$
+#
+
+PROJECT = rtems_gdb
+EDITION = 1
+
+include $(top_srcdir)/project.am
+include $(top_srcdir)/main.am
+
+GENERATED_FILES = intro.texi swarch.texi started.texi commands.texi \
+ trouble.texi example.texi
+
+COMMON_FILES += $(top_srcdir)/common/cpright.texi
+
+FILES =
+
+info_TEXINFOS = rtems_gdb.texi
+rtems_gdb_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
+
+#
+# Process Automatically Generated Files
+#
+
+intro.texi: intro.t
+ $(BMENU2) -p "Top" \
+ -u "Top" \
+ -n "Software Architecture" < $< > $@
+
+swarch.texi: swarch.t
+ $(BMENU2) -p "Introduction" \
+ -u "Top" \
+ -n "Getting Started" < $< > $@
+
+started.texi: started.t
+ $(BMENU2) -p "Software Architecture" \
+ -u "Top" \
+ -n "Commands" < $< > $@
+
+commands.texi: commands.t
+ $(BMENU2) -p "Getting Started Attaching To The System" \
+ -u "Top" \
+ -n "Troubleshooting" < $< > $@
+
+trouble.texi: trouble.t
+ $(BMENU2) -p "Commands Thread control" \
+ -u "Top" \
+ -n "Debug Session Example" < $< > $@
+
+example.texi: example.t
+ $(BMENU2) -p "Troubleshooting Debug server not present" \
+ -u "Top" \
+ -n "" < $< > $@
+
+EXTRA_DIST = commands.t example.t intro.t started.t swarch.t trouble.t
+
+CLEANFILES += rtems_gdb.info