summaryrefslogtreecommitdiffstats
path: root/doc/rtems_gdb/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/rtems_gdb/Makefile.am')
-rw-r--r--doc/rtems_gdb/Makefile.am59
1 files changed, 59 insertions, 0 deletions
diff --git a/doc/rtems_gdb/Makefile.am b/doc/rtems_gdb/Makefile.am
new file mode 100644
index 0000000000..78c7c9feaf
--- /dev/null
+++ b/doc/rtems_gdb/Makefile.am
@@ -0,0 +1,59 @@
+#
+# COPYRIGHT (c) 1988-1999.
+# On-Line Applications Research Corporation (OAR).
+# All rights reserved.
+#
+# $Id$
+#
+
+AUTOMAKE_OPTIONS = foreign
+
+PROJECT=rtems_gdb
+
+include $(top_srcdir)/project.am
+
+COMMON_FILES=$(top_srcdir)/common/cpright.texi $(top_builddir)/common/setup.texi
+
+GENERATED_FILES= \
+ intro.texi swarch.texi started.texi commands.texi trouble.texi example.texi
+
+FILES=
+
+info_TEXINFOS = rtems_gdb.texi
+rtems_gdb_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
+
+#
+# Process Automatically Generated Files
+#
+
+intro.texi: intro.t
+ $(BMENU) -p "Top" \
+ -u "Top" \
+ -n "Software Architecture" $<
+
+swarch.texi: swarch.t
+ $(BMENU) -p "Introduction" \
+ -u "Top" \
+ -n "Getting Started" $<
+
+started.texi: started.t
+ $(BMENU) -p "Software Architecture" \
+ -u "Top" \
+ -n "Commands" $<
+
+commands.texi: commands.t
+ $(BMENU) -p "Getting Started Attaching To The System" \
+ -u "Top" \
+ -n "Troubleshooting" $<
+
+trouble.texi: trouble.t
+ $(BMENU) -p "Commands Thread control" \
+ -u "Top" \
+ -n "Debug Session Example" $<
+
+example.texi: example.t
+ $(BMENU) -p "Troubleshooting Debug server not present" \
+ -u "Top" \
+ -n "" $<
+
+EXTRA_DIST = *.t