summaryrefslogtreecommitdiffstats
path: root/doc/posix1003.1/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/posix1003.1/Makefile.am')
-rw-r--r--doc/posix1003.1/Makefile.am135
1 files changed, 68 insertions, 67 deletions
diff --git a/doc/posix1003.1/Makefile.am b/doc/posix1003.1/Makefile.am
index 6f94255d78..cceafb6dfe 100644
--- a/doc/posix1003.1/Makefile.am
+++ b/doc/posix1003.1/Makefile.am
@@ -6,123 +6,124 @@
# $Id$
#
-AUTOMAKE_OPTIONS = foreign
+AUTOMAKE_OPTIONS = foreign 1.4
-PROJECT=posix1003_1
+PROJECT = posix1003_1
+EDITION = 1
include $(top_srcdir)/project.am
-COMMON_FILES=$(top_srcdir)/common/cpright.texi $(top_builddir)/common/setup.texi
+GENERATED_FILES = ch01.texi ch02.texi ch03.texi ch04.texi ch05.texi \
+ ch06.texi ch07.texi ch08.texi ch09.texi ch10.texi ch11.texi ch12.texi \
+ ch13.texi ch14.texi ch15.texi ch16.texi ch17.texi ch18.texi ch19.t \
+ ch19.texi
-GENERATED_FILES=ch01.texi ch02.texi ch03.texi ch04.texi ch05.texi \
- ch06.texi ch07.texi ch08.texi ch09.texi ch10.texi \
- ch11.texi ch12.texi ch13.texi ch14.texi ch15.texi \
- ch16.texi ch17.texi ch18.texi ch19.t ch19.texi
+COMMON_FILES = $(top_srcdir)/common/setup.texi $(top_srcdir)/common/cpright.texi
-FILES= preface.texi
+FILES = preface.texi
info_TEXINFOS = posix1003_1.texi
posix1003_1_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
-ch01.texi: ch01.t
- $(BMENU) -c -p "Preface" \
+$(srcdir)/ch01.texi: ch01.t
+ $(BMENU2) -c -p "Preface" \
-u "Top" \
- -n "Terminology and General Requirements" $<
+ -n "Terminology and General Requirements" < $< > $@
-ch02.texi: ch02.t
- $(BMENU) -c -p "Conformance" \
+$(srcdir)/ch02.texi: ch02.t
+ $(BMENU2) -c -p "Conformance" \
-u "Top" \
- -n "Process Primitives" $<
+ -n "Process Primitives" < $< > $@
-ch03.texi: ch03.t
- $(BMENU) -c -p "Execution-Time Symbolic Constants for Portability Specifications" \
+$(srcdir)/ch03.texi: ch03.t
+ $(BMENU2) -c -p "Execution-Time Symbolic Constants for Portability Specifications" \
-u "Top" \
- -n "Process Environment" $<
+ -n "Process Environment" < $< > $@
-ch04.texi: ch04.t
- $(BMENU) -c -p "Delay Process Execution" \
+$(srcdir)/ch04.texi: ch04.t
+ $(BMENU2) -c -p "Delay Process Execution" \
-u "Top" \
- -n "Files and Directories" $<
+ -n "Files and Directories" < $< > $@
-ch05.texi: ch05.t
- $(BMENU) -c -p "Get Configurable System Variables" \
+$(srcdir)/ch05.texi: ch05.t
+ $(BMENU2) -c -p "Get Configurable System Variables" \
-u "Top" \
- -n "Input and Output Primitives" $<
+ -n "Input and Output Primitives" < $< > $@
-ch06.texi: ch06.t
- $(BMENU) -c -p "Get Configurable Pathname Variables" \
+$(srcdir)/ch06.texi: ch06.t
+ $(BMENU2) -c -p "Get Configurable Pathname Variables" \
-u "Top" \
- -n "Device- and Class-Specific Functions" $<
+ -n "Device- and Class-Specific Functions" < $< > $@
-ch07.texi: ch07.t
- $(BMENU) -c -p " Asynchronous File Synchronization" \
+$(srcdir)/ch07.texi: ch07.t
+ $(BMENU2) -c -p " Asynchronous File Synchronization" \
-u "Top" \
- -n "Language-Specific Services for the C Programming Language" $<
+ -n "Language-Specific Services for the C Programming Language" < $< > $@
-ch08.texi: ch08.t
- $(BMENU) -c -p "Set Foreground Process Group ID" \
+$(srcdir)/ch08.texi: ch08.t
+ $(BMENU2) -c -p "Set Foreground Process Group ID" \
-u "Top" \
- -n "System Databases" $<
+ -n "System Databases" < $< > $@
-ch09.texi: ch09.t
- $(BMENU) -c -p "Pseudo-Random Sequence Generation Functions" \
+$(srcdir)/ch09.texi: ch09.t
+ $(BMENU2) -c -p "Pseudo-Random Sequence Generation Functions" \
-u "Top" \
- -n "Data Interchange Format" $<
+ -n "Data Interchange Format" < $< > $@
-ch10.texi: ch10.t
- $(BMENU) -c -p "User Database Access" \
+$(srcdir)/ch10.texi: ch10.t
+ $(BMENU2) -c -p "User Database Access" \
-u "Top" \
- -n "Synchronization" $<
+ -n "Synchronization" < $< > $@
-ch11.texi: ch11.t
- $(BMENU) -c -p "Multiple Volumes" \
+$(srcdir)/ch11.texi: ch11.t
+ $(BMENU2) -c -p "Multiple Volumes" \
-u "Top" \
- -n "Memory Management" $<
+ -n "Memory Management" < $< > $@
-ch12.texi: ch12.t
- $(BMENU) -c -p "Waiting on a Condition" \
+$(srcdir)/ch12.texi: ch12.t
+ $(BMENU2) -c -p "Waiting on a Condition" \
-u "Top" \
- -n "Execution Scheduling" $<
+ -n "Execution Scheduling" < $< > $@
-ch13.texi: ch13.t
- $(BMENU) -c -p "Remove a Shared Memory Object" \
+$(srcdir)/ch13.texi: ch13.t
+ $(BMENU2) -c -p "Remove a Shared Memory Object" \
-u "Top" \
- -n "Clocks and Timers" $<
+ -n "Clocks and Timers" < $< > $@
-ch14.texi: ch14.t
- $(BMENU) -c -p "Change the Priority Ceiling of a Mutex" \
+$(srcdir)/ch14.texi: ch14.t
+ $(BMENU2) -c -p "Change the Priority Ceiling of a Mutex" \
-u "Top" \
- -n "Message Passing" $<
+ -n "Message Passing" < $< > $@
-ch15.texi: ch15.t
- $(BMENU) -c -p "High Resolution Sleep" \
+$(srcdir)/ch15.texi: ch15.t
+ $(BMENU2) -c -p "High Resolution Sleep" \
-u "Top" \
- -n "Thread Management" $<
+ -n "Thread Management" < $< > $@
-ch16.texi: ch16.t
- $(BMENU) -c -p "Get Message Queue Attributes" \
+$(srcdir)/ch16.texi: ch16.t
+ $(BMENU2) -c -p "Get Message Queue Attributes" \
-u "Top" \
- -n "Thread-Specific Data" $<
+ -n "Thread-Specific Data" < $< > $@
-ch17.texi: ch17.t
- $(BMENU) -c -p "Dynamic Package Initialization" \
+$(srcdir)/ch17.texi: ch17.t
+ $(BMENU2) -c -p "Dynamic Package Initialization" \
-u "Top" \
- -n "Thread Cancellation" $<
+ -n "Thread Cancellation" < $< > $@
-ch18.texi: ch18.t
- $(BMENU) -c -p "Thread-Specific Data Key Deletion" \
+$(srcdir)/ch18.texi: ch18.t
+ $(BMENU2) -c -p "Thread-Specific Data Key Deletion" \
-u "Top" \
- -n "Compliance Summary" $<
+ -n "Compliance Summary" < $< > $@
ch19.t: ch01.t ch02.t ch03.t ch04.t ch05.t ch06.t ch07.t ch08.t ch09.t \
- ch10.t ch11.t ch12.t ch13.t ch14.t ch15.t ch16.t ch17.t ch18.t \
- summarize
+ ch10.t ch11.t ch12.t ch13.t ch14.t ch15.t ch16.t ch17.t ch18.t \
+ summarize
./summarize >ch19.t
-ch19.texi: ch19.t
- $(BMENU) -c -p "List of Cancellation Points" \
+$(srcdir)/ch19.texi: ch19.t
+ $(BMENU2) -c -p "List of Cancellation Points" \
-u "Top" \
- -n "Command and Variable Index" $<
+ -n "Command and Variable Index" < $< > $@
noinst_SCRIPTS = summarize