summaryrefslogtreecommitdiffstats
path: root/doc/posix1003.1/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/posix1003.1/Makefile.am')
-rw-r--r--doc/posix1003.1/Makefile.am129
1 files changed, 129 insertions, 0 deletions
diff --git a/doc/posix1003.1/Makefile.am b/doc/posix1003.1/Makefile.am
new file mode 100644
index 0000000000..6f94255d78
--- /dev/null
+++ b/doc/posix1003.1/Makefile.am
@@ -0,0 +1,129 @@
+#
+# COPYRIGHT (c) 1988-1999.
+# On-Line Applications Research Corporation (OAR).
+# All rights reserved.
+#
+# $Id$
+#
+
+AUTOMAKE_OPTIONS = foreign
+
+PROJECT=posix1003_1
+
+include $(top_srcdir)/project.am
+
+COMMON_FILES=$(top_srcdir)/common/cpright.texi $(top_builddir)/common/setup.texi
+
+GENERATED_FILES=ch01.texi ch02.texi ch03.texi ch04.texi ch05.texi \
+ ch06.texi ch07.texi ch08.texi ch09.texi ch10.texi \
+ ch11.texi ch12.texi ch13.texi ch14.texi ch15.texi \
+ ch16.texi ch17.texi ch18.texi ch19.t ch19.texi
+
+FILES= preface.texi
+
+info_TEXINFOS = posix1003_1.texi
+posix1003_1_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
+
+ch01.texi: ch01.t
+ $(BMENU) -c -p "Preface" \
+ -u "Top" \
+ -n "Terminology and General Requirements" $<
+
+ch02.texi: ch02.t
+ $(BMENU) -c -p "Conformance" \
+ -u "Top" \
+ -n "Process Primitives" $<
+
+ch03.texi: ch03.t
+ $(BMENU) -c -p "Execution-Time Symbolic Constants for Portability Specifications" \
+ -u "Top" \
+ -n "Process Environment" $<
+
+ch04.texi: ch04.t
+ $(BMENU) -c -p "Delay Process Execution" \
+ -u "Top" \
+ -n "Files and Directories" $<
+
+ch05.texi: ch05.t
+ $(BMENU) -c -p "Get Configurable System Variables" \
+ -u "Top" \
+ -n "Input and Output Primitives" $<
+
+ch06.texi: ch06.t
+ $(BMENU) -c -p "Get Configurable Pathname Variables" \
+ -u "Top" \
+ -n "Device- and Class-Specific Functions" $<
+
+ch07.texi: ch07.t
+ $(BMENU) -c -p " Asynchronous File Synchronization" \
+ -u "Top" \
+ -n "Language-Specific Services for the C Programming Language" $<
+
+ch08.texi: ch08.t
+ $(BMENU) -c -p "Set Foreground Process Group ID" \
+ -u "Top" \
+ -n "System Databases" $<
+
+ch09.texi: ch09.t
+ $(BMENU) -c -p "Pseudo-Random Sequence Generation Functions" \
+ -u "Top" \
+ -n "Data Interchange Format" $<
+
+ch10.texi: ch10.t
+ $(BMENU) -c -p "User Database Access" \
+ -u "Top" \
+ -n "Synchronization" $<
+
+ch11.texi: ch11.t
+ $(BMENU) -c -p "Multiple Volumes" \
+ -u "Top" \
+ -n "Memory Management" $<
+
+ch12.texi: ch12.t
+ $(BMENU) -c -p "Waiting on a Condition" \
+ -u "Top" \
+ -n "Execution Scheduling" $<
+
+ch13.texi: ch13.t
+ $(BMENU) -c -p "Remove a Shared Memory Object" \
+ -u "Top" \
+ -n "Clocks and Timers" $<
+
+ch14.texi: ch14.t
+ $(BMENU) -c -p "Change the Priority Ceiling of a Mutex" \
+ -u "Top" \
+ -n "Message Passing" $<
+
+ch15.texi: ch15.t
+ $(BMENU) -c -p "High Resolution Sleep" \
+ -u "Top" \
+ -n "Thread Management" $<
+
+ch16.texi: ch16.t
+ $(BMENU) -c -p "Get Message Queue Attributes" \
+ -u "Top" \
+ -n "Thread-Specific Data" $<
+
+ch17.texi: ch17.t
+ $(BMENU) -c -p "Dynamic Package Initialization" \
+ -u "Top" \
+ -n "Thread Cancellation" $<
+
+ch18.texi: ch18.t
+ $(BMENU) -c -p "Thread-Specific Data Key Deletion" \
+ -u "Top" \
+ -n "Compliance Summary" $<
+
+ch19.t: ch01.t ch02.t ch03.t ch04.t ch05.t ch06.t ch07.t ch08.t ch09.t \
+ ch10.t ch11.t ch12.t ch13.t ch14.t ch15.t ch16.t ch17.t ch18.t \
+ summarize
+ ./summarize >ch19.t
+
+ch19.texi: ch19.t
+ $(BMENU) -c -p "List of Cancellation Points" \
+ -u "Top" \
+ -n "Command and Variable Index" $<
+
+noinst_SCRIPTS = summarize
+
+EXTRA_DIST = *.t compliance_list summarize